Wstęp

Informacje ogólne
Pomoc przygotowana dla Odkurzacz 12.1.

( Franmo Software 2003-2010 )
Kontakt: franmo@o2.pl
Strona: www.franmo.pl
Forum: www.odkurzacz.info

Do większości przycisków dostępna jest krótka podpowiedź, która ułatwia szybkie zapoznanie się z poleceniem. Najedź kursorem myszki na wybrany przycisk i odczekaj około 2 sekund na pojawienie się podpowiedzi (o ile nie została ona wyłączona). Jeśli chcesz ponownie skorzystać z podręcznika pomocy, kliknij logo programu [image] dostępne w lewym górnym rogu głównego okna aplikacji.

Następnie z menu kliknij polecenie "Pomoc" lub "Pomoc > Podręcznik pomocy".
Możesz też skorzystać z pomocy bezpośrednio przez menu Start systemu Windows. W tym celu, kliknij w systemie kolejno "Start > Programy > Odkurzacz [wersja] > Pomoc > Podręcznik pomocy".

W pomocy zastosowano pola informacyjne, które w zależności od stopnia ważności przyjęły następujące oznaczenie:

Mało ważne informacje (głównie spis treści)

Średnio ważne informacje

Bardzo ważne informacje

Obiekty, które są bezpośrednio związane z funkcją programu zostały wyróżnione zieloną czcionką: "Przykładowa funkcja".


Licencja

Licencja programu "Odkurzacz"
Producentem i pełnoprawnym autorem programu jest Maciej Opaliński.

( Franmo Software 2003-2010 )
Kontakt: franmo@o2.pl
Strona: www.franmo.pl
Forum: www.odkurzacz.info

Postanowienia ogólne
Program Odkurzacz i jego dodatkowe moduły stanowią całość jako pakiet aplikacji zwanym dalej Odkurzacz.
"Odkurzacz" jest darmowy, na licencji Freeware.

Ograniczenia
Program "Odkurzacz" może być używany bez ponoszenia opłat w domu, w firmach i instytucjach państwowych, organach administracji państwowej, samorządowej jak i rządowej.
Program "Odkurzacz" może być rozpowszechniany bez ponoszenia opłat w czasopismach, na stronach WWW, forach, sieciach wymiany plików - w niezmienionej formie, w jakiej został dostarczony z instalatorem lub oddzielnej aktualizacji.

Zabronione jest rozpowszechnianie bazy sygnatur i wewnętrznych składników aplikacji "Odkurzacz" w programach innych producentów.
Za aplikację "Odkurzacz", nie mogą być pobierane opłaty przez osoby trzecie, np.: ze sprzedaży w serwisach aukcyjnych oraz ze sprzedaży na płytach CD, DVD lub innych nośnikach (nie dotyczy to czasopism np.: komputerowych, gdzie zbiór różnych programów jest dodatkiem do tego czasopisma).
W przypadku innych form sprzedaży, wymagane jest skontaktowanie się z autorem i jednocześnie dystrybutorem programu "Odkurzacz" w celu wydania stosownego pozwolenia.

Cel programu
"Odkurzacz" rozpoznaje ponad 5000 zbędnych obiektów z ponad 380 aplikacji. Obiekty te zajmują cenne miejsce na dysku i powodują ogólne spowolnienie operacji na dysku (także przez zwiększoną fragmentację plików). "Odkurzacz" umożliwia pozbycie się wielu zbędnych obiektów, co sprawia, że system "Microsoft Windows" zaczyna pracować szybciej.

"Odkurzacz" rozpoznaje:
- obiekty tymczasowe (np.: z przeglądarek internetowych),
- kopie zapasowe (w tym kopie rejestru),
- raporty, dzienniki zdarzeń,
- obce pliki językowe (np.: z krajów Korea, Japonia, Chiny, Albania),
- zbędne pliki multimedialne,
- obiekty szkodliwe (np.: utworzone przez oprogramowanie szpiegujące),
- obiekty pozostawione po odinstalowanych programach,
- obiekty niecenzuralne (będące nieodpowiednie dla Twojego dziecka).

Aktualizowane bazy sygnatur zapewniają wykrywanie nowych zbędnych obiektów. Przy pierwszym czyszczeniu, możesz zwolnić 500MB - 1,5GB miejsca na dyskach.
"Odkurzacz" jest przeznaczony dla każdego, kto chce utrzymać porządek i sprawną pracę systemu "Microsoft Windows" poprzez usunięcia zbędnych obiektów.

Gwarancja autora
Aplikacja "Odkurzacz" nie zawiera szkodliwego kodu, który by świadomie uszkadzał lub szpiegował Twój system.
Nie mogę zagwarantować Ci, że po przeczyszczeniu programem "Odkurzacz", nie nastąpią skutki uboczne w innych aplikacjach. Jednak dzięki stale aktualizowanym składników programu "Odkurzacz" ryzyko jest zminimalizowane do zera.

"Odkurzacz" tworzy kopię bezpieczeństwa usuwanych obiektów, dzięki czemu możesz je odzyskać jeśli zauważysz problemy. Ryzyko jest zmniejszone do minimum w trybach skanowania: "Bezpieczny", "Bezpieczny (Ekspres)", a także w trybach: "Pośredni" i "Pośredni (Ekspres)".

Wewnętrzne składniki
Program "Odkurzacz" korzysta z:
1. Grafiki PNG i ikon ICO pochodzących z następujących stron:
http://www.kde-look.org/index.php?xcontentmode=22
http://www.customxp.net/PngFactory

2. Dźwięków w formacie WAV skonwertowanych do MP3 w programie Audacity pochodzących z systemów "Windows Vista/7".

3. Biblioteki BASS.dll pochodzącej ze strony:
http://www.un4seen.com/


Odkurzacz > Wstęp

Wybierz interesujacą Cię kategorię pomocy:

Rozpoczęcie pracy

  • Uruchomienie
  • Interfejs

Wybór obiektów do przeszukania

Rozpoczęcie skanowania

  • Skanowanie
  • Szczegóły znalezionego obiektu

Usuwanie po skanowaniu

  • Zaznaczanie znalezionych obiektów
  • Wykluczanie znalezionych obiektów
  • Wyrzucanie znalezionych obiektów z listy
  • Tworzenie kopii bezpieczeństwa
  • Usuwanie zaznaczonych obiektów z dysku

Wybór trybu

  • Wybór trybu skanowania
  • Definicje filtrowania
  • Przykłady z wykorzystaniem definicji
  • Dodawanie własnych filtrów szukających
  • Usuwanie lub edycja własnych filtrów szukających

Opisy filtrów

  • Legenda
  • Szukanie frazy
  • Statystyki

Kopie i raporty

  • Odzyskiwanie z kopii
  • Zaawansowane odzyskiwanie
  • Usuwanie kopii z dysku
  • Przeglądanie raportów
  • Usuwanie raportów z dysku

Wykluczenia

  • Wykluczenia lokalne plików
  • Wykluczenia globalne plików
  • Wykluczenia globalne folderów
  • Definicje filtrowania
  • Przykłady z wykorzystaniem definicji
  • Dodawanie własnych filtrów wykluczających
  • Usuwanie lub edycja własnych filtrów wykluczających


Odkurzacz > Rozpoczęcie pracy

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Możesz też skorzystać z pomocy technicznej prowadzonej przez autora lub poprzez Oficjalne Forum programu Odkurzacz.

Uruchomienie

Aplikacja wymaga najwyższych uprawnień (Administratora), gdyż wymaga dostępu do plików zlokalizowanych na całym dysku, w tym partycji systemowej.

Aplikacja wymaga, aby przeglądarki internetowe na czas skanowania i czyszczenia były wyłączone. Jeśli Odkurzacz stwierdzi uruchomione przeglądarki, pominie je przy czyszczeniu.

Interfejs
Interfejs aplikacji został przystosowany do szybkiego wyboru najważniejszych poleceń. Główne menu, zwane wstążką, zostało podzielone na zakładki kategoriami. Natomiast dostęp do innych funkcji aplikacji zlokalizowany został po kliknięciu w logo programu [image]. Aby skonfigurować aplikacje, kliknij logo programu, a następnie "Ustawienia".

Z poziomu menu dostępnego poprzez logo programu, masz możliwość także szybkiego uruchomienia dodatkowych modułów dołączonych do Odkurzacza, skorzystania z pomocy technicznej, czy zarządzania wynikami skanowania (np.: w celu późniejszego wczytania przeanalizowanych przez autora wyników skanowania).

Do każdego przycisku dostępny jest krótki opis funkcji. Jeśli masz problem z nieznanym Ci przyciskiem, najedź na niego kursorem myszki i odczekaj 2 sekundy na pojawienie się podpowiedzi. Jeśli podpowiedź nie pokazuje się, może to oznaczać, że podpowiedzi są wyłączone w ustawieniach programu Odkurzacz.


Odkurzacz > Wybór obiektów do przeszukania

Jeśli masz problemy z podstawową obsługą aplikacji, przejdź do rozpoczęcia pracy.

Ustalenie obiektów
Przy pierwszym uruchomieniu aplikacji Odkurzacz, musisz ustalić obiekty, które chcesz przeszukać. Mogą to być całe partycje lub wybrane foldery na dyskach. Można ustalić do przeszukania także napędy wymienne, napędy optyczne lub dyski sieciowe.

Wybierz zakładkę "Skanowanie". Następne w sekcji "Skanuj" kliknij ikonkę folderu po prawej. Pojawi się okno "Wybierz dyski lub foldery" z wyborem aktualnie dostępnych partycji na wszystkich zainstalowanych w systemie dyskach twardych.

Zaznacz pole wyboru przy obiekcie. W ten sposób ustalasz, które obiekty mają zostać przeszukane.

Odkurzacz automatycznie pominie zdefiniowany obiekt, do którego nie ma dostępu. Np.: dodając do przeszukania napęd optyczny w którym nie ma już płyty.

Obiekt do którego Odkurzacz nie ma dostępu do przeszukiwania jest oznaczany czerwonym tłem na liście wyboru obiektów w zakładce "Skanowanie" w sekcji "Skanuj" i poleceniem "Wybierz dyski lub foldery".

Nie możesz edytować lub usuwać obiektów do przeszukania z ikoną klucza [image]. Są to obiekty ustalane przez aplikację. Możesz edytować lub usuwać tylko zdefiniowane przez siebie obiekty z ikoną człowieka.

Jeśli chcesz zdefiniować inny obiekt, np.: folder, kliknij przycisk "Dodaj". Następnie wskaż obiekt z okna dialogowego i kliknij "OK". Jeśli chcesz usunąć zdefiniowany przez siebie obiekt do przeszukania, podświetl go, a następnie kliknij przycisk "Usuń". Jeśli chcesz zmienić lokalizację zdefiniowanego przez siebie obiektu do przeszukania, podświetl go, a następne po prawej stronie podświetlenia kliknij ikonę ołówka [image]. Następnie wskaź nową lokalizację i kliknij w oknie dialogowym przycisk "OK".

Jeśli wskazany obiekt już jest zawarty w innym zaznaczonym do przeszukania obiekcie, otrzymasz stosowany komunikat "Konflikt wpisów".

Możesz np.: wskazać do przeszukania całą partycję "C:\". Ale folder z tej partycji "C:\Folder" już nie, gdyż folder jest zawarty w wybranym obiekcie "C:\".

Po zakończeniu wyboru obiektów do przeszukania, kliknij przycisk "Zastosuj". Wskazane obiekty zostaną zapamiętane.
Możesz nie zapisywać wybranych obiektów do przeszukania i od razu rozpocząć skanowanie. Odkurzacz będzie pamiętał wybrane obiekty do przeszukania do czasu jego zamknięcia.

Z wybranych do przeszukania obiektów korzysta moduł Monitor Czystości Dysku.
Jeśli nie zapamiętasz wyboru obiektów do przeszukania, moduł nie będzie mógł przeprowadzić skanowania i otrzymasz stosowany komunikat "Nieprawidłowy wybór".

Pierwsze zapisanie obiektów do przeszukania spowoduje automatyczne rozpoczęcie skanowania przez Odkurzacz. Jeśli już wcześniej zdefiniowo obiekty do skanowania kliknij w zakładce "Skanowanie" w sekcji "Skanuj" przycisk "Start" [image]. Aby przerwać skanowanie w tej samej sekcji kliknij przycisk "Stop" [image] i oczekuj na zatrzymanie skanowania.


Odkurzacz > Rozpoczęcie skanowania

Jeśli masz problemy z ustaleniem obiektów do przeszukania, przejdź do wyboru obiektów do przeszukania.

Skanowanie
Pierwsze zapisanie obiektów do przeszukania spowoduje automatyczne rozpoczęcie skanowania przez Odkurzacz. Jeśli już wcześniej zdefiniowo obiekty do skanowania kliknij w zakładce "Skanowanie" w sekcji "Skanuj" przycisk "Start" [image]. Aby przerwać skanowanie w tej samej sekcji kliknij przycisk "Stop" [image] i oczekuj na zatrzymanie skanowania.

Jeśli masz otwartą przeglądarkę lub inny program, który musi zostać zamknięty do czasu usunięcia jego zbędnych plików, otrzymasz stosowny komunikat "Zamknij program, aby go oczyścić". Zamknięte aplikacje zostaną ponownie uruchomione przy kończeniu pracy z programem Odkurzacz.

Wybranie z w/w komunikatu polecenia "Kontynuuj skanowanie" spowoduje, iż Odkurzacz pominie zbędne pliki z programu, który nie został zamknięty z poziomu Odkurzacza.

W trakcie skanowania na głównej liście w zakładce "Skanowanie", będą pojawiać się znalezione zbędne obiekty. Każdy obiekt oznaczony jest ikoną typu oraz stosownym opisem przeznaczenia pliku.

Rozróżniane są następujące grupy obiektów i towarzyszące im ikony grupy:
- "Internetowe",
- "Tymczasowe",
- "Raporty, dzienniki",
- "Kopie zmian w rejestrze",
- "Kopie zmian w systemie",
- "Zbędne informacyjne",
- "Zbędne historii",
- "Multimedialne, językowe",
- "Niesklasyfikowane",

oraz:

- "Niecenzuralne" (jako osobny tryb skanowania),

Obiety "Niesklasyfikowane" oznaczone są ikoną wykrzyknika [image].
Usunięcie tak oznaczonych obiektów może być niebezpieczne i nie jest zalecane dla początkujących użytkowników.

Obiekty "Niecenzuralne" oznaczone sa ikoną cenzury [image].
Obiekty tak oznaczone zawierają w nazwie niecenzuralne słowo, więc teoretycznie zawartość pliku może być nieodpowiednia dla Twojego dziecka.

Szczegóły znalezionego obiektu
Aby dowiedzieć się więcej o znalezionym obiekcie, kliknij dwukrotnie myszką podświetlony wpis obiektu. Otworzy się okno "Szczegóły obiektu".

Z poziomu tego okna możesz dowiedzieć się między innymi o:
- "Poziomie ryzyka" usunięcia pliku,
- "Sygnaturze" (tzw.: filtrom) dzięki której plik został odnaleziony,
- "Spotykalności" obiektu, czyli jego częstotliwości występowania,
- "Opisie szczegółowym", z uwzględnieniem grupy do której należy obiekt.

Z poziomu tego okna, możesz uruchomić plik, w tym celu kliknij przycisk "Uruchom obiekt".
Z dostępnego menu możesz wybrać, aby obiekt został uruchomiony przez skojarzony w systemie z tym obiektem program przez polecenie "Uruchom obiekt przez skojarzony program". Lub podejrzeć obiekt w notatniku, przez polecenie "Uruchom obiekt w notatniku" (polecenie nie zalecane dla dużych obiektów).
Aby przejść bezpośrednio do lokalizacji pliku na dysku, wybierz polecenie "Idź do lokalizacji".

Z poziomu tego okna możesz wykluczyć obiekt, w tym celu kliknij przycisk "Wykluczenia".
Z dostępnego menu wybierz polecenie "Ignoruj obiekt z tej lokalizacji.". Spowoduje to dodanie obiektu do "Wykluczeń lokalnych plików" według następującego schematu "X:\abc.xyz". Oznacza to, że wykluczony zostanie konkretny obiekt z dysku.
Z dostępnego menu wybierz polecenie "Ignoruj nazwę obiektu.". Spowoduje to dodanie obiektu do "Wykluczeń globalnych plików" według następującego schematu "abc.xyz". Oznacza to, że wykluczone zostaną wszystkie pliki o takiej samej nazwie i rozszerzeniu, niezależnie od lokalizacji pliku.
Z dostępnego menu wybierz polecenie "Ignoruj typ obiektu.". Spowoduje to dodanie obiektu do "Wykluczeń globalnych plików" według następującego schematu "*.xyz". Oznacza to, że wykluczone zostaną wszystkie pliki o takim samym rozszerzeniu, niezależnie od nazwy i lokalizacji pliku.


Odkurzacz > Usuwanie po skanowaniu

Jeśli nie rozpoczęto jeszcze skanowania lub lista wyników jest pusta, przejdź do rozpoczęcia skanowania lub wczytaj zapisane wyniki z pliku.

Zaznaczanie znalezionych obiektów
Aby zaznaczyć znaleziony obiekt na głównej liście w zakładce "Skanowanie", wybierz pole wyboru znajdujące się przy każdym obiekcie po jego lewej stronie przy ikonie grupy. W ten sposób zaznaczasz znalezione obiekty do dalszych czynności.

Jeśli chcesz szybko zaznaczyć wszystkie znalezione obiekty, kliknij w zakładce "Skanowanie" w sekcji "Wybierz" przycisk "Zaznacz wsz." [image] . Jeśli chcesz zaznaczyć tylko określone grupy obiektów, kliknij w tej samej sekcji przycisk [image]. Z dostępnego menu wybierz odpowiednią grupę.
Jeśli chcesz szybko odznaczyć wszystkie znalezione obiekty, kliknij w zakładce "Skanowanie" w sekcji "Wybierz" przycisk "Odznacz wsz." [image] . Jeśli chcesz odznaczyć tylko określone grupy obiektów, kliknij w tej samej sekcji przycisk [image]. Z dostępnego menu wybierz odpowiednią grupę.

Możesz wybierać znalezione obiekty za pomocą podświetlania wpisów. W tym celu kliknij w zakładce "Skanowanie" w sekcji "Wybierz" przycisk "Podświetl" [image]. Z dostępnego menu wybierz odpowiednie polecenie.

Obiety "Niesklasyfikowane" oznaczone są ikoną wykrzyknika [image].
Usunięcie tak oznaczonych obiektów może być niebezpieczne i nie jest zalecane dla początkujących użytkowników.

Polecenie "Zaznacz wsz." ignoruje automatyczny wybór obiektów z tej grupy.

Obiekty "Niecenzuralne" oznaczone sa ikoną cenzury [image].
Obiekty tak oznaczone zawierają w nazwie niecenzuralne słowo, więc teoretycznie zawartość pliku może być nieodpowiednia dla Twojego dziecka.

Wykluczanie znalezionych obiektów
Jeśli chcesz szybko dodać zaznaczone obiekty do "Wykluczeń lokalnych plików" kliknij w zakładce "Skanowanie" w sekcji "Usuń" przycisk [image].

Aby dodać każdy obiekt z osobna do "Wykluczeń globalnych plików", kliknij dwukrotnie myszką podświetlony wpis obiektu. Otworzy się okno "Szczegóły obiektu". Kliknij przycisk "Wykluczenia".
Z dostępnego menu wybierz polecenie "Ignoruj nazwę obiektu.". Spowoduje to dodanie obiektu do "Wykluczeń globalnych plików" według następującego schematu "abc.xyz". Oznacza to, że wykluczone zostaną wszystkie pliki o takiej samej nazwie i rozszerzeniu, niezależnie od lokalizacji pliku.
Z dostępnego menu wybierz polecenie "Ignoruj typ obiektu.". Spowoduje to dodanie obiektu do "Wykluczeń globalnych plików" według następującego schematu "*.xyz". Oznacza to, że wykluczone zostaną wszystkie pliki o takim samym rozszerzeniu, niezależnie od nazwy i lokalizacji pliku.

Wyrzucanie znalezionych obiektów z listy
Jeśli chcesz uporządkować listę wyników z obiektów, których na razie nie chcesz jeszcze usuwać, możesz posłużyć się poleceniem wyrzucającym zaznaczone obiekty z listy wyników. W tym celu w zakładce "Skanowanie" w sekcji "Usuń" kliknij przycisk [image]. Zaznaczone obiekty zostaną wyrzucone z listy bez tworzenia kopii bezpieczeństwa.

Tworzenie kopii bezpieczeństwa
Odkurzacz automatycznie tworzy kopię usuwanych obiektów. Jeśli chcesz samodzielnie utworzyć kopię wybranym obiektom możesz skorzystać z poleceń dostępnych w zakładce "Skanowanie" w sekcji "Kopia". Dostęp do utworzonych kopii znajduje się w zakładce "Kopie i raporty".

Jeśli kopia nie jest tworzona, może to oznaczać, że została wyłączona w ustawieniach programu lub jest tymczasowo wyłączona poleceniem blokady kopii [image] dostępnym w zakładce "Skanowanie" w sekcji "Kopia".

Usuwanie zaznaczonych obieków z dysku
Jeśli jesteś gotowy(a) do usunięcia znalezionych obiektów z dysku, kliknij przycisk "Usuń" [image] w zakładce "Skanowanie" w sekcji "Usuń". Odkurzacz najpierw przystąpi do tworzenia kopii zaznaczonym obiektom, a następnie zacznie usuwać obiekty z dysku i jednocześnie z listy wyników. Jeśli chcesz przerwać usuwanie obiektów z dysku, kliknij przycisk "Anuluj" [image] w zakładce "Skanowanie" w sekcji "Usuń".

Niektóre obiekty mogą nie zostać usunięte z dysku, gdyż są zablokowane przed edycją. Takie obiekty otrzymają odpowiedni opis o problemie z ich usunięciem oraz ikonę grupy [image].
Jeśli zamknięcie przeglądarek internetowych lub innych aplikacji nie powoduje odblokowania ich usunięcia, to tak oznaczone obiekty należy pominąć lub całkowicie wykluczyć ze skanowania (dodając do "Wykluczeń lokalnych plików").


Odkurzacz > Wybór trybu

Jeśli chcesz utworzyć filtry wykluczające, przejdź do dodawania własnych filtrów wykluczających.
Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Wybór trybu skanowania
Aby określić dokładność i typ skanowania, należy wybrać tryb skanowania. Dostępne są następujące tryby skanowania wyszukujące zbędne pliki:
- "Bezpieczny" (domyślny),
- "Bezpieczny Ekspres" (szuka tylko pliki, które mogły pojawić się ponownie na dysku),
- "Pośredni"
- "Pośredni Ekspres" (szuka tylko pliki, które mogły pojawić się ponownie na dysku),
- "Zaawansowany" (tylko dla doświadczonych użytkowników)
- "Zaawansowany Ekspres" (szuka tylko pliki, które mogły pojawić się ponownie na dysku),
- "Użytkownika" (w tym trybie zdefiniowane mogą być tylko filtry szukające przez użytkownika).

Zmień tryb skanowania na wyższy w zależności od swojego doświadczenia pracy z programem.
Jeśli jesteś użytkownikiem początkującym, zawsze stosuj tryb "Bezpieczny" lub jego szybszą odmianę "Bezpieczny Ekspres".

Dostępny jest też jeden tryb skanowania wyszukujący niecenzuralne pliki:
- "Cenzura".

Tryb skanowania "Cenzura", możesz zastosować, aby wyszukać na dysku pliki multimedialne o charakterystycznych niecenzuralnych nazwach. Pliki te mogą zawierać treści szkodliwe dla Twojego dziecka lub nieodpowiednie dla innych osób korzystających z tego samego komputera.
Odkurzacz rozpoznaje takie pliki tylko po nazwie - nie sprawdza zawartości.

Tryb ten może być użyty w module "Monitor Czystości Dysku " do stałego monitorowania niecenzuralnych obiektów na dysku.

Obiekty znalezione w tym trybie są oznaczane ikoną grupy [image].
Mogą być (tak samo jak w przypadku pozostałych trybów) usuwane z dysku, dodawane do wykluczeń lub archiwizowane do kopii bezpieczeństwa przed bezpośrednim usunięciem.

Po wybraniu trybu skanowania, kliknij przycisk "Zapisz" [image] w zakładce "Wybór trybu" w sekcji "Tryb", aby zastosować go na stałe. Jeśli tego nie zrobisz, możesz korzystać z wybranego trybu do zamknięcia aplikacji. Opcja wyboru trybu skanowania dostępna jest także w ustawieniach.

Definicje filtrowania
Przed dodaniem własnego filtra musisz zapoznać się z definicjami i parametrami filtrów.

Dozwolone znaki specjalne:
1. "*" (gwiazdka)
Stosowanie gwiazdki powoduje zastąpienie wielu dowolnych znaków w nazwie pliku. Np.: stosując "k*t.txt" można odnaleźć pliki, które mają różne znaki między literami "k" i "t", np.: "kret.txt, kotlet.txt, kit.txt".

Zabronione jest stosowanie więcej niż jednej gwiazdki po sobie, np.: "k***t.txt".

2. "?" (pytajnik)
Stosowanie pytajnika powoduje zastąpienie jednego dowolnego znaku w nazwie pliku. Np.: stosując "k?t.txt" można odnaleźć pliki, które mają różny znak między literami "k" i "t", np.: "kot.txt, kat.txt, kit.txt".

Dozwolone jest stosowanie więcej niż jednego pytajnika po sobie, np.: "k???t.txt".

3. "[parametr]" (nawiasy kwadratowe)
Umożliwia zdefiniowanie zestawu dodatkowych instrukcji. Definiowanie zestawu instrukcji należy rozpocząć od nawiasu kwadratowego lewego [ i zamknąć zestaw instrukcji nawiasem kwadratowym prawym ]. Np.: stosując "k[i,o]t.txt" można odnaleźć pliki, które mają tylko znaki "i" oraz "o" między literami "k" i "t", np.: "kit.txt, kot.txt".

Zabronione jest stosowanie "*" (gwiazdki) oraz "?" (pytajnika) jako parametru, np.: "k[*abc?]t.txt".

4. "-" (minus)
Umożliwia wykluczenie ciągu jako jednego znaku np.: alfabetu lub liczb zamiast wypisywać cały alfabet lub wszystkie liczby. Np.: stosując "plik-nr[0-8].txt" można odnaleźć pliki, które mają po nazwie pliku liczbę od 0 do 8, np.: "plik-nr4.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

5. ";" (średnik)
Umożliwia określenie kolejnego zestawienia parametrów dla definicji "[parametr]" (nawiasy kwadratowe). Np.: stosując "plik-nr[0-3;5;9].txt" można odnaleźć pliki, które mają po nazwie pliku liczbę 0, 1, 2, 3, 5 lub 9, np.: "plik-nr2.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

6. "!" (wykrzyknik)
Umożliwia wykluczenie znaku lub ciągu znaków podanych przed parametrem dla definicji "[parametr]" (nawiasy kwadratowe). Np.: stosując "plik-nr[!0-3;!9].txt" można odnaleźć pliki, które nie mają po nazwie pliku liczby 0, 1, 2, 3 lub 9, np.: "plik-nr5.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

Jego zdefiniowanie w dowolnym parametrze jest uznawane w każdym. Powinien więc być stosowany z zachowaniem poprawności wszystkich zdefiniowanych parametrów w nawiasach kwadratowych, np.: zapis "plik-nr[!0;9].txt" będzie uznany za wykluczenie liczb "0" i "9" tak samo jak zapis "plik-nr[!0;!9].txt".

Przykłady z wykorzystaniem definicji
a[!0]c.txt
(znajdzie tylko plik o ciągu aXc.txt, gdzie X nie może być cyfrą "0"),

a[!0-3;a-c]c.txt (lub) a[!0-3;!a-c]c.txt
(znajdzie wszystkie pliki o ciągu aXc.txt, gdzie X nie może być cyframi od "0" do "3" i nie może być literami alfabetu od "a" do "c"),

a[a-c]c.txt
(znajdzie tylko trzy pliki o ciągu aXc.txt, gdzie X jest literami alfabetu od "a" do "c", a więc będą to pliki "aac.txt", "abc.txt" oraz "acc.txt"),

??????[abc].log = ??????[a-c].log = ??????[a;b;c].log
(znajdzie pliki o długości 11 znaków w nazwie pliku i rozszerzeniem LOG, przy czym 7-my znak w nazwie pliku musi być znakiem "a", "b" lub "c"),

*[0-9][0-9]*.*
(znajdzie wszystkie pliki, które posiadają w nazwie (w dowolnym miejscu oprócz skrajnych końców) dwuznakowy ciąg znaków od "00" do "99"),

20[0;1][0-9] podatki.doc
(znajdzie dokumenty w formacie DOC, które na początku nazwy pliku posiadają zapis roku 2000-2019, np.: "2009 podatki.doc").

Dodawanie własnych filtrów szukających
Aby dodać własny filtr szukający do wybranego trybu skanowania przejdź do zakładki "Wybór trybu", a następnie w sekcji "Edytor bazy" wprowadź odpowiednio zdefiniowany filtr. Następnie w tej samej sekcji kliknij przycisk [image], aby dodać filtr szukający do wybranego trybu. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image]. Filtry szukające zdefiniowane przez użytkownika oznaczane są ikoną lupki z człowiekiem [image] i posiadają zielone tło.

Dodawanie własnych filtrów szukających przeznaczone jest tylko dla doświadczonych użytkowników, zapoznanych z pracą z programem Odkurzacz i znającymi podstawowe definicje filtrowania.

Wprowadzanie własnych filtrów szukających wiąże się ze zwiększoną ilością oznaczania w wynikach plików jako niesklasyfikowane, gdyż Odkurzacz nie posiada oddzielnej bazy opisów obiektów definiowanych przez użytkownika.

Zalecane jest dodawanie własnych filtrów szukających do oddzielnego trybu "Użytkownika". Obiekty w ten sposób odseparowane w innym trybie łatwiej prześledzić i ocenić.

Usuwanie lub edycja własnych filtrów szukających
Filtry szukające zdefiniowane przez użytkownika oznaczane są ikoną lupki z człowiekiem [image] i posiadają zielone tło. Tylko te typy filtrów możesz edytować i usuwać.

Aby edytować własny filtr szukający z wybranego trybu skanowania przejdź do zakładki "Wybór trybu" i wybierz odpowiedni tryb skanowania. Następnie podświetl swój filtr szukający na liście filtrów. Przejdź do sekcji "Edytor bazy". Pole wprowadzenia danych powinno wypełnić się zdefiniowanym przez Ciebie filtrem. Wprowadź poprawki do definiowanego filtra szukającego. Następnie w tej samej sekcji kliknij przycisk [image], aby zmienić filtr szukający. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image].

Aby usunąć własny filtr szukający z wybranego trybu skanowania przejdź do zakładki "Wybór trybu" i wybierz odpowiedni tryb skanowania. Zaznacz pola wyboru przy swoich filtrach. Możesz posłużyć się opcją wyświetlenia tylko filtrów użytkownika w sekcji "Statystyka". Następnie powracając do sekcji "Edytor bazy" kliknij przycisk [image], aby usunąć filtry szukające. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image] .

Jeśli chcesz pozbyć się wszystkich swoich filtrów szukających i filtrów wykluczających, kliknij logo programu, a następnie przejdź kolejno do "Ustawienia > Naprawa ustawień". W komunikacie "Przywracanie ustawień" wybierz polecenie "Usuń filtry użytkownika".


Odkurzacz > Opisy filtrów

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Legenda
Odkurzacz posiada bazę opisów filtrów, dzięki której może sklasyfikować zbędne pliki np.: po grupie. Aby odczytać opisy filtrów przejdź do zakładki "Opisy filtrów". Po wczytaniu listy możesz wyodrębnić wybraną grupę. W tym celu przejdź do sekcji "Legenda", a następnie kliknij wybraną grupę, np.: "Tymczasowe". W ten sposób, wyselekcjonujesz wszystkie zbędne pliki tymczasowe. Jeśli chcesz wyświetlić ponownie pełną listę opisów, kliknij w sekcji "Legenda" przycisk [image].

Szukanie frazy
Jeśli chcesz wyszukać frazę w opisach, przejdź do sekcji "Szukaj frazy". W pole edycji wpisz szukaną frazę i kliknij przycisk lupki [image] lub wciśnij klawisz Enter. Jeśli wskazana fraza zostanie znaleziona, pole edycji przyjmie tło zielone, a na liście opisów zostanie podświetlony wpis w którym znajduje się szukana fraza.
Kliknij ponownie przycisk lupki [image], aby ponowić dalsze szukanie. Kolejny znaleziony wpis zostanie podświetlony. Klikaj ponownie przycisk lupki [image], aż pole edycji przyjmie tło czerwone - oznacza to iż szukanie dotarło do końca listy. Kliknij ponownie przycisk lupki [image], aby szukanie rozpoczęło się od początku listy.

Jeśli chcesz rozpocząć szukanie np.: od połowy listy, przesuń suwak skrolowania listy do jej połowy. Następnie podświetl wybrany wpis na liście opisów. W sekcji "Szukaj frazy" w polu edycji wpisz szukaną frazę i kliknij przycisk lupki [image] - szukanie rozpocznie się od podświetlonego wpisu do końca listy.

Niektóre opisy mają żółte lub czerwone tło.
Czerwonym tłem oznaczane są opisy dla "Filtrów nieobsługiwanych". Te filtry nie są używane w programie, gdyż są potencjalnie niebezpieczne w użyciu.
Żółtym tłem oznaczane są opisy dla "Folderów szkodliwych". Te filtry stosowane są tylko w module Monitor Porzuconych Folderów do oznaczania folderów utworzonych przez szkodliwe oprogramowanie.

Statystyki
Jeśli chcesz dowiedzieć się takie informacje jak:
- data wydania bazy sygnatur,
- ważność bazy sygnatur,
- ilość filtrów w bazie sygnatur,
- ilość całkowitego zyskanego miejsca po czyszczeniach,
- ilość wszystkich usuniętych plików po czyszczeniach,
przejdź do zakładki "Opisy filtrów" i sekcji "Statyst.". Następnie kliknij przycisk "Podgląd" [image] . Otworzy się okno "Statystyka". Dostęp do tego okna możliwy jest też poprzez kliknięcie w logo programu [image], a następnie wybór z menu polecenia "Statystyki".


Odkurzacz > Kopie i raporty

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Odzyskiwanie z kopii
Przejdź do zakładki "Kopie i raporty". Górna lista zawiera utworzone przy czyszczeniu kopie bezpieczeństwa.
Aby odzyskać usunięte obiekty z wybranych kopii, zaznacz pola wyboru. Możesz posłużyć się sortowaniem, aby określić, które kopie zostały utworzone niedawno. Jeśli masz problem ze zidentyfikowaniem kopii, posłuż się "Zaawansowanym odzyskiwaniem", aby podejrzeć jej zawartość.
Po wybraniu kopii, przejdź do sekcji "Zarządzaj kopiami", a następnie kliknij przycisk "Odzyskaj" [image]. Odczekaj, aż Odkurzacz wypakuje pliki z kopii do oryginalnych lokalizacji.

Kopie z których pliki pomyślnie zostały odzyskane oznaczone są ikoną [image]. W przypadku problemów kopie oznaczone zostaną ikoną [image], wpis przyjmie tło czerwone, a użytkownik otrzyma stosowny komunikat.

Odzyskiwanie z kopii może zakończyć się niepowodzeniem, gdy odzyskiwany jest plik z kopii w miejsce istniejącego i używanego (zablokowanego do edycji) przez zewnętrzny program.

Spróbuj zamknąć wszystkie programy w tym przeglądarki internetowe. Jeśli wiesz o który plik chodzi lub program, który blokuje jego podmianę, możesz spróbować zamknąć tylko ten znany program.

Jeśli masz problemy z odzyskaniem z kopii, możesz posłużyć się poleceniami dostępnymi z poziomu "Odzyskiwania zaawansowanego". Zastosuj wypakowanie plików bez nadpisywania lub wybierz inną lokalizację do odzyskania plików.

Jeśli kopia bezpieczeństwa jest uszkodzona, odzyskanie plików może już być nie możliwe.

Zaawansowane odzyskiwanie
Jeśli masz problem ze zidentyfikowaniem kopii lub problem z odzyskaniem z niej plików, posłuż się "Zaawansowanym odzyskiwaniem".
W tym celu w zakładce "Kopie i raporty" w sekcji "Zarządzaj kopiami" kliknij przycisk "Odzysk zaawansowany". Możesz też podwójnie kliknąć prawym przyciskiem myszki na wybranej kopii. Otworzy się okno "Zaawansowane odzyskiwanie plików z kopii bezpieczeństwa".
Wybierz z listy dostępną kopię poprzez jej podświetlenie. Na dole okna pojawi się lista plików zawartych w kopii.
Jeśli chcesz wyszukać plik w kopii, posłuż się polem edycji wpisania szukanej frazy, a następnie kliknij przycisk lupki [image]. Wpis z szukaną frazą zostanie podświetlony na liście plików w kopii, a pole edycji przyjmie tło zielone. W przypadku nie znalezienia szukanej frazy, pole edycji przyjmie tło czerwone.

Jeśli masz problemy z odzyskiwaniem plików z kopii, możesz użyć opcji odzyskania bez nadpisywania. W tym celu w oknie "Zaawansowane odzyskiwanie plików z kopii bezpieczeństwa" w sekcji "Opcje odzyskiwania I" zaznacz opcję "Odzyskaj wszystko bez nadpisywania". Następnie kliknij przycisk "Odzyskaj pliki z wybranej kopii" i oczekuj na zakończenie operacji i stosowny komunikat.

Jeśli chcesz odzyskać pliki z kopii do innej lokalizacji, w tym samym oknie w sekcji "Opcje odzyskiwania I" zaznacz opcję "Odzyskaj wszystko z nadpisaniem", natomiast w sekcji "Opcje odzyskiwania II" zaznacz opcję "Inna lokalizacja". Następnie w polu edycji wprowadź miejsce wypakowania lub wskaż je za pomocą przycisku ".". Jeśli chcesz, aby wypakowane pliki z kopii zawarte były w oryginalnych folderach, zaznacz w sekcji "Opcje odzyskiwania II" opcję "Łączenie z oryginalnymi ścieżkami". Następnie kliknij przycisk "Odzyskaj pliki z wybranej kopii" i oczekuj na zakończenie operacji i stosowny komunikat.

Usuwanie kopii z dysku
Aby usunąć wybrane kopie z dysku, przejdź do zakładki "Kopie i raporty". Górna lista zawiera utworzone przy czyszczeniu kopie bezpieczeństwa. Zaznacz pola wyboru przy kopiach, które chcesz usunąć. Możesz posłużyć się sortowaniem, aby określić, które kopie są najstarsze. Kopie przedawnione Odkurzacz automatycznie oznacza ikoną [image]. Następnie w sekcji "Zarządzaj kopiami" kliknij przycisk "Usuń" [image]. Wybrane kopie zostaną usunięte z dysku. Możesz też usunąć ręcznie kopie z dysku. W tym celu kliknij dwukrotnie na wybraną kopię - zostanie otworzona jej lokalizacja na dysku.

Zalecane jest usunięcie kopii minimum po kilku dniach pracy z komputerem.

Kopia jest kompresowana, aby zajmować mniej miejsca niż oryginalne pliki na dysku. Jeśli opcja automatycznego usuwania przestarzałych kopii jest włączona, Odkurzacz usunie kopie przy zamykaniu. Oznacza to, że nawet jeśli kopia jest przedawniona, masz możliwość odzyskania z niej plików do zamknięcia programu.

Przeglądanie raportów
Przejdź do zakładki "Kopie i raporty". Dolna lista zawiera utworzone po czyszczeniu raporty. Zaznacz pola wyboru przy raportach, które chcesz przejrzeć. Następnie w sekcji "Zarządzanie raportami" kliknij przycisk "Przejrzyj" [image]. Możesz też podwójnie kliknąć prawym przyciskiem myszki na wybranym raporcie.

Usuwanie raportów z dysku
Aby usunąć wybrane raporty z dysku, przejdź do zakładki "Kopie i raporty". Dolna lista zawiera utworzone po czyszczeniu raporty. Zaznacz pola wyboru przy raportach, które chcesz usunąć. Możesz posłużyć się sortowaniem, aby określić, które raporty są najstarsze. Następnie w sekcji "Zarządzaj raportami" kliknij przycisk "Usuń" [image]. Wybrane raporty zostaną usunięte z dysku. Możesz też usunąć ręcznie raport z dysku. W tym celu kliknij dwukrotnie na wybrany raport - zostanie otworzona jego lokalizacja na dysku.


Odkurzacz > Wykluczenia

Jeśli chcesz utworzyć filtry szukające, przejdź do dodawania własnych filtrów szukających.
Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Wykluczenia lokalne plików
Wykluczenia lokalne plików stosowane są do ignorowania określonych plików z określonych lokalizacji. Oznacza to, że jeden filtr lokalnie wykluczający plik odnosi się do konkretnego jednego pliku.
Aby przejść do wykluczeń lokalnych plików, kliknij zakładkę "Wykluczenia", a następnie w sekcji "Wybór wykluczeń" kliknij przycisk "Wyklucz lokalnie plik".
Jeśli chcesz wykluczyć grupę plików skorzystaj z "Wykluczenia globalnego plików" lub "Wykluczenia globalnego folderów", które umożliwiają wprowadzanie "Definicji filtrowania".

Jeśli chcesz usunąć pliki z dysku określone dla tego typu wykluczeń, zaznacz pola wyboru przy swoich filtrach z tłem zielonym. Przejdź do sekcji "Usuń" i następnie kliknij przycisk [image]. Otrzymasz stosowny komunikat potwierdzenia akcji usunięcia plików z dysku.

Tylko z poziomu "Wykluczeń lokalnych plików" masz możliwość usunięcia tych plików z dysku, gdyż znajdują się tam bezpośrednie odwołania do plików.

Wykluczenia globalne plików
Wykluczenia globalne plików stosowane są do ignorowania grup plików z możliwością użycia "Definicji filtrowania". Nie mogą zawierać bezpośredniego odwołania do konkretnego pliku na dysku (nie mogą zawierać ścieżki do pliku). Oznacza to, że jeden filtr globalnie wykluczający plik odnosi się do wielu plików, które mogą być w każdej lokalizacji.
Aby przejść do wykluczeń globalnych plików, kliknij zakładkę "Wykluczenia", a następnie w sekcji "Wybór wykluczeń" kliknij przycisk "Wyklucz globalnie plik". Jeśli chcesz wykluczyć konkretny jeden plik skorzystaj z "Wykluczenia lokalnego plików". Jeśli chcesz wykluczyć wiele plików z danej lokalizacji skorzystaj z "Wykluczenia globalnego folderów".

Wykluczenia globalne folderów
Wykluczenia globalne folderów stosowane są do ignorowania wszystkich plików z danego folderu z możliwością użycia "Definicji filtrowania". Nie mogą zawierać bezpośredniego odwołania do konkretnego folderu na dysku (nie mogą zawierać ścieżki do folderu). Oznacza to, że jeden filtr globalnie wykluczający folder odnosi się do wielu folderów, które mogą być w każdej lokalizacji.

Aby uniknąć pomijania wielu tak samo nazwanych folderów, stosuje się filtr w jak nawiększym stopniu odpowiadający ścieżką do folderu, który chcemy pomijać.

Np.: chcąc wykluczyć folder "Folder 2" na dysku "C:\" w lokalizacji "C:\Folder 1\Folder 2\Folder 3", zamiast stosować filtr "*Folder 2*", można zastosować dokładniejsze odwołanie stosując filtr "*Folder 1\Folder 2*".
Jest mniejsze prawdopodobieństwo, że "Folder 2" zostanie pominięty w innej lokalizacji, gdyż zdefiniowano dokładniejszą lokalizację.

Aby przejść do wykluczeń globalnych folderów, kliknij zakładkę "Wykluczenia", a następnie w sekcji "Wybór wykluczeń" kliknij przycisk "Wyklucz globalnie folder". Jeśli chcesz wykluczyć konkretny jeden plik skorzystaj z "Wykluczenia lokalnego plików". Jeśli chcesz wykluczyć grupę plików skorzystaj z "Wykluczenia globalnego plików".

Definicje filtrowania
Przed dodaniem własnego filtra musisz zapoznać się z definicjami i parametrami filtrów.

Definicje filtrowania można stosować tylko dla "Wykluczeń globalnych plików" i "Wykluczeń globalnych folderów".
Zabronione jest stosowanie znaków specjalnych do filtrów "Wykluczeń lokalnych plików".

Dozwolone znaki specjalne:
1. "*" (gwiazdka)
Stosowanie gwiazdki powoduje zastąpienie wielu dowolnych znaków w nazwie pliku. Np.: stosując "k*t.txt" można wykluczyć pliki, które mają różne znaki między literami "k" i "t", np.: "kret.txt, kotlet.txt, kit.txt".

Zabronione jest stosowanie więcej niż jednej gwiazdki po sobie, np.: "k***t.txt".

2. "?" (pytajnik)
Stosowanie pytajnika powoduje zastąpienie jednego dowolnego znaku w nazwie pliku. Np.: stosując "k?t.txt" można wykluczyć pliki, które mają różny znak między literami "k" i "t", np.: "kot.txt, kat.txt, kit.txt".

Dozwolone jest stosowanie więcej niż jednego pytajnika po sobie, np.: "k???t.txt".

3. "[parametr]" (nawiasy kwadratowe)
Umożliwia zdefiniowanie zestawu dodatkowych instrukcji. Definiowanie zestawu instrukcji należy rozpocząć od nawiasu kwadratowego lewego [ i zamknąć zestaw instrukcji nawiasem kwadratowym prawym ]. Np.: stosując "k[i,o]t.txt" można wykluczyć pliki, które mają tylko znaki "i" oraz "o" między literami "k" i "t", np.: "kit.txt, kot.txt".

Zabronione jest stosowanie "*" (gwiazdki) oraz "?" (pytajnika) jako parametru, np.: "k[*abc?]t.txt".

4. "-" (minus)
Umożliwia wykluczenie ciągu jako jednego znaku np.: alfabetu lub liczb zamiast wypisywać cały alfabet lub wszystkie liczby. Np.: stosując "plik-nr[0-8].txt" można wykluczyć pliki, które mają po nazwie pliku liczbę od 0 do 8, np.: "plik-nr4.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

5. ";" (średnik)
Umożliwia określenie kolejnego zestawienia parametrów dla definicji "[parametr]" (nawiasy kwadratowe). Np.: stosując "plik-nr[0-3;5;9].txt" można wykluczyć pliki, które mają po nazwie pliku liczbę 0, 1, 2, 3, 5 lub 9, np.: "plik-nr2.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

6. "!" (wykrzyknik)
Umożliwia wykluczenie znaku lub ciągu znaków podanych przed parametrem dla definicji "[parametr]" (nawiasy kwadratowe). Np.: stosując "plik-nr[!0-3;!9].txt" można wykluczyć pliki, które nie mają po nazwie pliku liczby 0, 1, 2, 3 lub 9, np.: "plik-nr5.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

Jego zdefiniowanie w dowolnym parametrze jest uznawane w każdym. Powinien więc być stosowany z zachowaniem poprawności wszystkich zdefiniowanych parametrów w nawiasach kwadratowych, np.: zapis "plik-nr[!0;9].txt" będzie uznany za wykluczenie liczb "0" i "9" tak samo jak zapis "plik-nr[!0;!9].txt".

Przykłady z wykorzystaniem definicji
a[!0]c.txt
(wykluczy tylko plik o ciągu aXc.txt, gdzie X nie może być cyfrą "0"),

a[!0-3;a-c]c.txt (lub) a[!0-3;!a-c]c.txt
(wykluczy wszystkie pliki o ciągu aXc.txt, gdzie X nie może być cyframi od "0" do "3" i nie może być literami alfabetu od "a" do "c"),

a[a-c]c.txt
(wykluczy tylko trzy pliki o ciągu aXc.txt, gdzie X jest literami alfabetu od "a" do "c", a więc będą to pliki "aac.txt", "abc.txt" oraz "acc.txt"),

??????[abc].log = ??????[a-c].log = ??????[a;b;c].log
(wykluczy pliki o długości 11 znaków w nazwie pliku i rozszerzeniem LOG, przy czym 7-my znak w nazwie pliku musi być znakiem "a", "b" lub "c"),

*[0-9][0-9]*.*
(wykluczy wszystkie pliki, które posiadają w nazwie (w dowolnym miejscu oprócz skrajnych końców) dwuznakowy ciąg znaków od "00" do "99"),

20[0;1][0-9] podatki.doc
(wykluczy dokumenty w formacie DOC, które na początku nazwy pliku posiadają zapis roku 2000-2019, np.: "2009 podatki.doc").

Dodawanie własnych filtrów wykluczających
Aby dodać własny filtr wykluczający, przejdź do zakładki "Wykluczenia", a następnie w sekcji "Wybór wykluczeń" kliknij odpowiedni typ wykluczeń. Następnie przejdź do sekcji "Edytor bazy". Posłuż się przyciskiem [image], aby wskazać konkretny plik lub folder z dysku (jeśli jesteś w "Wyklucz globalnie plik", przycisk ten będzie nie aktywny). W polu edycji możesz nanieść poprawki do definiowanego filtru. Następnie w tej samej sekcji kliknij przycisk [image], aby dodać filtr wykluczający. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę". Filtry wykluczające zdefiniowane przez użytkownika oznaczane są ikoną kłódki z człowiekiem [image] i posiadają zielone tło.

Dodawanie własnych filtrów wykluczających przeznaczone jest tylko dla doświadczonych użytkowników, zapoznanych z pracą z programem Odkurzacz i znającymi podstawowe definicje filtrowania.

Wprowadzanie własnych filtrów wykluczających wiąże się z pomijaniem określonych plików w wynikach.

Usuwanie lub edycja własnych filtrów wykluczających
Filtry wykluczające zdefiniowane przez użytkownika oznaczane są ikoną kłódki z człowiekiem [image] i posiadają zielone tło. Tylko te typy filtrów możesz edytować i usuwać.

Aby edytować własny filtr wykluczający przejdź do zakładki "Wykluczenia". Następnie przejdź do sekcji "Wybór wykluczeń" i wybierz odpowiedni typ wykluczeń. Podświetl swój filtr wykluczający na liście filtrów. Przejdź do sekcji "Edytor bazy". Pole wprowadzenia danych powinno wypełnić się zdefiniowanym przez Ciebie filtrem. Wprowadź poprawki do definiowanego filtra wykluczającego.

Definicje filtrowania można stosować tylko dla "Wykluczeń globalnych plików" i "Wykluczeń globalnych folderów".
Zabronione jest stosowanie znaków specjalnych do filtrów "Wykluczeń lokalnych plików".

Dla "Wykluczeń lokalnych plików" należy podać poprawną lokalizację pliku, typu "dysk:\lokalizacja\plik".

Następnie w tej samej sekcji kliknij przycisk [image], aby zmienić filtr wykluczający. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę".

Aby usunąć własny filtr wykluczający przejdź do zakładki "Wykluczenia". Następnie przejdź do sekcji "Wybór wykluczeń" i wybierz odpowiedni typ wykluczeń. Zaznacz pola wyboru przy swoich filtrach wykluczających z tłem zielonym. Możesz posłużyć się opcją wyświetlenia tylko filtrów użytkownika w sekcji "Statystyka". Następnie powracając do sekcji "Edytor bazy" kliknij przycisk [image], aby usunąć filtry wykluczające. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę".

Jeśli chcesz pozbyć się wszystkich swoich filtrów szukających i filtrów wykluczających, kliknij logo programu, a następnie przejdź kolejno do "Ustawienia > Naprawa ustawień". W komunikacie "Przywracanie ustawień" wybierz polecenie "Usuń filtry użytkownika".


Globalne ustawienia

Wybierz interesujacą Cię kategorię pomocy:

Globalne ustawienia

  • Dostęp na hasło
  • Lokalizacja kopii bezpieczeństwa
  • Podpowiedzi
  • Zmiana interfejsu
  • Zmiana dźwięków
  • Zapis i odczyt profilu użytkownika
  • Naprawa ustawień


Globalne ustawienia

Globalne ustawienia
Poniżej dostępne są najważniejsze globalne ustawienia. Uruchom program Odkurzacz, następnie kliknij w logo programu [image]. Z menu wybierz polecenie "Ustawienia" lub "Ustawienia > Zmiana ustawień".

Ustawienia globalne definiowane są tylko z poziomu głównej aplikacji Odkurzacz. Ich zmiana odnosi skutek w każdym module lub większości.

Dostęp na hasło
Zabezpieczenie dostępu na hasło przydaje się, gdy z komputera korzysta wiele osób. Opcja zabezpieczy przed nieautoryzowanym dostępem do programu już przy jego uruchomieniu. W celu zabezpieczenia przejdź do kategorii "Profil użytkownika > Zabezpieczenia". Następnie zaznacz opcję "Włącz ochronę hasłem, przed nieautoryzowanym dostępem" i obydwu polach "Hasło" i "Potwierdź hasło" podaj hasło składające się z minimum 6 znaków. Kliknij "Zastosuj", aby zapisać i wyjść z okna "Ustawienia".

Lokalizacja kopii bezpieczeństwa
Jeśli zajdzie potrzeba zmiany miejsca, gdzie mają być przechowywane kopie, przejdź do kategorii "Kopie bezpieczeństwa". Następnie dla pola "Aktualny folder przechowujący utworzone kopie" za pomocą przycisku "..." wskaż nową lokalizację na kopie bezpieczeństwa. Jeśli ręcznie podany folder na kopie nie istnieje, zostanie on utworzony. Kliknij "Zastosuj", aby zapisać i wyjść z okna "Ustawienia".

Podpowiedzi
Jest to pomoc dla początkujących użytkowników, która w postaci podpowiedzi pojawia się po najechaniu kursorem myszki na wybranym przycisku:

Opcja dla zaawansowanych użytkowników może stać się z czasem zbędna. Aby wyłączyć tą opcję, przejdź do kategorii "Komunikaty". Następnie odzaznacz opcję "Pokaż podpowiedzi do przycisków". Kliknij "Zastosuj", aby zapisać i wyjść z okna "Ustawienia".

Zmiana interfejsu
Zmiany wyglądu interfejsu można dokonać na kilka sposobów. Przejdź do kategorii "Interfejs ogólny".
1. Jeśli chcesz wyłączyć wbudowane obramowanie okien, odznacz opcję "Korzystaj z wbudowanego obramowania okien",
2. Jeśli chcesz skorzystać z innego obramowania okien, włącz opcję w pkt 1. oraz włącz opcję "Użyj alternatywnego obramowania okien". Następnie za pomocą przycisku "..." wskaż plik w formacie .SKN. Zmiana wyglądu obramowania okna nastąpi natychmiast.
3. Za pomocą opcji "Styl kolorów głównego menu" można zmienić styl kolorów tzw.: wstążki. Wybierz z menu odpowiedni styl. Zmiana wyglądu nastąpi natychmiast.
4. Jeśli chcesz zmienić cały interfejs, włącz opcję "Użyj zewnętrznego stylu". Następnie za pomocą przycisku "..." wskaż styl w formacie .ODKSKIN. Zmiana wyglądu nastąpi natychmiast.
5. Włącz opcję "Korzystaj z przeźroczystości". Następnie suwak obok stanie się aktywny. Ustal stopień przeźroczystości suwakiem.

Kliknij "Zastosuj", aby zapisać i wyjść z okna "Ustawienia".

Zmiana dźwięków
Przejdź do kategorii "Interfejs ogólny > Dźwięki". Następnie zaznacz pola wyboru przy dźwiękach, które mają być aktywne. Kliknij przycisk ">", aby odsłuchać dźwięk. Kliknij przycisk "...", a następnie wskaż lokalizację dźwięku w formacie .MP3, .WAV lub .OGG. Kliknij "Zastosuj", aby zapisać i wyjść z okna "Ustawienia".

Zapis i odczyt profilu użytkownika
Zapisanie ustawień do własnego pliku profilu może okazać się przydatne, gdy chcemy szybko ustalić te same ustawienia np.: na innym komputerze lub przywrócić po aktualizacji programu Odkurzacz. W tym celu przejdź do "Profil użytkownika" i kliknij przycisk "Zapisz profil użytkownika". Wskaż bezpieczne miejsce zapisania ustawień i kliknij w oknie dialogowym przycisk "Zapisz".
Aby przywrócić ustawienia z pliku, przejdź do "Profil użytkownika" i kliknij przycisk "Wczytaj profil użytkownika". Następnie wskaż lokalizację pliku profilu .ODK_PROFIL i kliknij w oknie dialogowym przycisk "Otwórz". Okno "Ustawień" zostanie zamknięte automatycznie.
Obydwie opcje zapisania i odczytania pliku profilu dostępne są także z poziomu menu głównego dostępnego w logo programu [image].

Naprawa ustawień
Jeśli aplikacja pracuje niestabilnie lub chcesz przywrócić domyślne ustawienia aplikacji, kliknij przycisk "Domyślne" w oknie "Ustawienia" lub przejdź do kategorii "Profil użytkownika" i kliknij przycisk "Napraw/Przywróć profil zalecany". W komunikacie dialogowym wybierz odpowiednią akcję. Okno "Ustawień" zostanie zamknięte automatycznie.
Opcja naprawy dostępna jest także z poziomu menu głównego dostępnego w logo programu [image].


Dodatkowe moduły

Wybierz interesujacą Cię kategorię pomocy:

Szybkie Czyszczenie Dysku

Monitor Czystości Dysku

Monitor Porzuconych Folderów

Menedżer Rejestru

Usuwanie Zablokowanych Plików


Szybkie Czyszczenie Dysku > Wstęp

Wybierz interesujacą Cię kategorię pomocy:

Rozpoczęcie pracy

  • Uruchomienie
  • Interfejs

Wybór obiektów do czyszczenia

Rozpoczęcie czyszczenia

Zarządzanie czyszczeniem

  • Definicje filtrowania
  • Przykłady z wykorzystaniem definicji
  • Dodawanie własnych filtrów czyszczących
  • Usuwanie lub edycja własnych filtrów czyszczących


Szybkie Czyszczenie Dysku > Rozpoczęcie pracy

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Możesz też skorzystać z pomocy technicznej prowadzonej przez autora lub poprzez Oficjalne Forum programu Odkurzacz.

Uruchomienie

Aplikacja wymaga najwyższych uprawnień (Administratora), gdyż wymaga dostępu do plików zlokalizowanych na całym dysku, w tym partycji systemowej.

Aplikacja wymaga, aby przeglądarki internetowe na czas czyszczenia były wyłączone. Jeśli moduł Szybkie Czyszczenie Dysku stwierdzi uruchomione przeglądarki, pominie je przy czyszczeniu.

Interfejs
Interfejs aplikacji został przystosowany do szybkiego wyboru najważniejszych poleceń. Główne menu, zwane wstążką, zostało podzielone na zakładki kategoriami. Natomiast dostęp do innych funkcji aplikacji zlokalizowany został po kliknięciu w logo programu [image]. Aby skonfigurować aplikacje, kliknij logo programu, a następnie "Ustawienia".

Z poziomu menu dostępnego poprzez logo programu, masz możliwość także szybkiego uruchomienia dodatkowych modułów, Odkurzacza lub skorzystania z pomocy technicznej.

Do każdego przycisku dostępny jest krótki opis funkcji. Jeśli masz problem z nieznanym Ci przyciskiem, najedź na niego kursorem myszki i odczekaj 2 sekundy na pojawienie się podpowiedzi. Jeśli podpowiedź nie pokazuje się, może to oznaczać, że podpowiedzi są wyłączone w ustawieniach programu Odkurzacz.


Szybkie Czyszczenie Dysku > Wybór obiektów do czyszczenia

Jeśli masz problemy z podstawową obsługą aplikacji, przejdź do rozpoczęcia pracy.
Jeśli chcesz ustalić nowe obiekty do czyszczenia, przejdź do zarządzania czyszczeniem.

Ustalenie obiektów do czyszczenia
Przy pierwszym uruchomieniu modułu, zostanie przeprowadzona "Detekcja folderów". Ma ona za zadanie odczytać lokalizacje, w których aplikacje przechowują tymczasowe składniki. Najczęściej są to przeglądarki internetowe. Moduł dokonuje sprawdzenia w ciągu kilku sekund.

Moduł Szybkie Czyszczenie Dysku może dokonać aktualizacji Twojego profilu o nowe obiekty do czyszczenia. Jeśli dostępna będzie aktualizacja, zostanie przeprowadzona ponowna "Detekcja folderów".

Jednocześnie, jeśli nie posiadałeś(aś) wcześniej zainstalowanej np.: przeglądarki "Opera", należy przeprowadzić ręcznie ponowną "Detekcję folderów" po jej zainstalowaniu. W ten sposób przeglądarka "Opera" zostanie rozpoznana i będzie mogła być czyszczona.

Po zakończonej detekcji, otrzymasz stosowny komunikat "Detekcja zakończona" i zostaniesz przeniesiony do zakładki "Zarządzanie czyszczeniem". Znajduje się tam lista z obiektami, które mogą zostać przeczyszczone. Są one automatycznie zaznaczone do czyszczenia poprzez pole wyboru. Jeśli nie chcesz czyścić któregoś z obiektów, po prostu odznacz pole wyboru.

Obiekty, których foldery na zbędne składniki nie zostały wykryte na dysku, będą odznaczone, o czym zostaniesz powiadomiony w komunikacie "Detekcja zakończona". Obiektów tych nie można zaznaczyć i posiadają czcionkę w kolorze czerwonym.

Jeśli nie chcesz czyszczenia np.: historii odwiedzonych stron z przeglądarki "Microsoft Internet Explorer", przejdź do zakładki "Zarządzanie czyszczeniem", odnajdź pozycję "Microsoft Internet Explorer - historia.", a następnie odznacz pole wyboru. Przejdź do sekcji "Edytor bazy" i kliknij przycisk "Zapisz bazę", aby wprowadzić zmiany.
Przejdź teraz do zakładki "Czyszczenie". Odznaczona przez Ciebie pozycja "Microsoft Internet Explorer - historia." już nie znajduje się na głównej liście obiektów do czyszczenia.

Jeśli chcesz tymczasowo wyłączyć obiekt z czyszczenia, możesz to zrobić z poziomu zakładki "Czyszczenie". Odznacz pole wyboru przy pozycji, której nie chcesz teraz przeczyścić. Tło odznaczonego wpisu stanie się czerwone.
Możesz posłużyć się opcją zaznaczania [image] lub odznaczania [image] według grupy dostępnej z poziomu menu, np.: "Internetowe". Opcje te dostępne są w zakładce "Czyszczenie" w sekcji "Wybierz".

Jeśli chcesz przejść do lokalizacji folderu zawierającego zbędne składniki z danego obiektu, kliknij dwukrotnie lewym przyciskiem myszki na podświetlonym wpisie obiektu w zakładce "Czyszczenie" lub zakładce "Zarządzanie czyszczeniem".


Szybkie Czyszczenie Dysku > Rozpoczęcie czyszczenia

Jeśli masz problemy z ustaleniem obiektów do czyszczenia, przejdź do wyboru obiektów do czyszczenia.

Czyszczenie
Aby rozpocząć czyszczenie zaznaczonych obiektów, przejdź do zakładki "Czyszczenie". W sekcji "Czyść" kliknij przycisk "Start" [image]. Oczekuj na zakończenie czyszczenia. Aby przerwać czyszczenie w tej samej sekcji kliknij przycisk "Stop" [image] i oczekuj na zatrzymanie czyszczenia.

Jeśli masz otwartą przeglądarkę lub inny program, który musi zostać zamknięty do czasu usunięcia jego zbędnych plików, otrzymasz stosowny komunikat "Zamknij program, aby go oczyścić. Zamknięte aplikacje zostaną ponownie uruchomione przy kończeniu pracy z modułem Szybkie Czyszczenie Dysku.

Wybranie z w/w komunikatu polecenia "Kontynuuj skanowanie" spowoduje, iż moduł Szybkie Czyszczenie Dysku pominie zbędne pliki z programu, który nie został zamknięty z poziomu modułu.

Na głównej liście w zakładce "Czyszczenie", będą oczyszczane kolejne pozycje. W każdej z pozycji pojawiać się będzie podsumowanie zyskanego miejsca i usuniętych plików. Każda pozycja oznaczona jest ikoną typu oraz stosownym opisem.

Jeśli chcesz wyłączyć komputer po zakończeniu czyszczenia, przed jego rozpoczęciem w zakładce "Czyszczenie" w sekcji "Komputer" kliknij przycisk "Wyłącz" [image] . Przycisk powinien mieć tło zaznaczenia, jeśli opcja wyłączenia komputera została aktywowana.


Szybkie Czyszczenie Dysku > Zarządzanie czyszczeniem

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Definicje filtrowania
Przed dodaniem własnego filtra czyszczącego musisz zapoznać się z definicjami i parametrami filtrów.

Dozwolone znaki specjalne:
1. "*" (gwiazdka)
Stosowanie gwiazdki powoduje zastąpienie wielu dowolnych znaków w nazwie pliku. Np.: stosując "k*t.txt" można odnaleźć pliki, które mają różne znaki między literami "k" i "t", np.: "kret.txt, kotlet.txt, kit.txt".

Zabronione jest stosowanie więcej niż jednej gwiazdki po sobie, np.: "k***t.txt".

2. "?" (pytajnik)
Stosowanie pytajnika powoduje zastąpienie jednego dowolnego znaku w nazwie pliku. Np.: stosując "k?t.txt" można odnaleźć pliki, które mają różny znak między literami "k" i "t", np.: "kot.txt, kat.txt, kit.txt".

Dozwolone jest stosowanie więcej niż jednego pytajnika po sobie, np.: "k???t.txt".

3. "[parametr]" (nawiasy kwadratowe)
Umożliwia zdefiniowanie zestawu dodatkowych instrukcji. Definiowanie zestawu instrukcji należy rozpocząć od nawiasu kwadratowego lewego [ i zamknąć zestaw instrukcji nawiasem kwadratowym prawym ]. Np.: stosując "k[i,o]t.txt" można odnaleźć pliki, które mają tylko znaki "i" oraz "o" między literami "k" i "t", np.: "kit.txt, kot.txt".

Zabronione jest stosowanie "*" (gwiazdki) oraz "?" (pytajnika) jako parametru, np.: "k[*abc?]t.txt".

4. "-" (minus)
Umożliwia wykluczenie ciągu jako jednego znaku np.: alfabetu lub liczb zamiast wypisywać cały alfabet lub wszystkie liczby. Np.: stosując "plik-nr[0-8].txt" można odnaleźć pliki, które mają po nazwie pliku liczbę od 0 do 8, np.: "plik-nr4.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

5. ";" (średnik)
Umożliwia określenie kolejnego zestawienia parametrów dla definicji "[parametr]" (nawiasy kwadratowe). Np.: stosując "plik-nr[0-3;5;9].txt" można odnaleźć pliki, które mają po nazwie pliku liczbę 0, 1, 2, 3, 5 lub 9, np.: "plik-nr2.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

6. "!" (wykrzyknik)
Umożliwia wykluczenie znaku lub ciągu znaków podanych przed parametrem dla definicji "[parametr]" (nawiasy kwadratowe). Np.: stosując "plik-nr[!0-3;!9].txt" można odnaleźć pliki, które nie mają po nazwie pliku liczby 0, 1, 2, 3 lub 9, np.: "plik-nr5.txt".

Definicja dostępna tylko w połączeniu z definicją "[parametr]" (nawiasy kwadratowe).

Jego zdefiniowanie w dowolnym parametrze jest uznawane w każdym. Powinien więc być stosowany z zachowaniem poprawności wszystkich zdefiniowanych parametrów w nawiasach kwadratowych, np.: zapis "plik-nr[!0;9].txt" będzie uznany za wykluczenie liczb "0" i "9" tak samo jak zapis "plik-nr[!0;!9].txt".

Przykłady z wykorzystaniem definicji
a[!0]c.txt
(znajdzie tylko plik o ciągu aXc.txt, gdzie X nie może być cyfrą "0"),

a[!0-3;a-c]c.txt (lub) a[!0-3;!a-c]c.txt
(znajdzie wszystkie pliki o ciągu aXc.txt, gdzie X nie może być cyframi od "0" do "3" i nie może być literami alfabetu od "a" do "c"),

a[a-c]c.txt
(znajdzie tylko trzy pliki o ciągu aXc.txt, gdzie X jest literami alfabetu od "a" do "c", a więc będą to pliki "aac.txt", "abc.txt" oraz "acc.txt"),

??????[abc].log = ??????[a-c].log = ??????[a;b;c].log
(znajdzie pliki o długości 11 znaków w nazwie pliku i rozszerzeniem LOG, przy czym 7-my znak w nazwie pliku musi być znakiem "a", "b" lub "c"),

*[0-9][0-9]*.*
(znajdzie wszystkie pliki, które posiadają w nazwie (w dowolnym miejscu oprócz skrajnych końców) dwuznakowy ciąg znaków od "00" do "99"),

20[0;1][0-9] podatki.doc
(znajdzie dokumenty w formacie DOC, które na początku nazwy pliku posiadają zapis roku 2000-2019, np.: "2009 podatki.doc").

Dodawanie własnych filtrów czyszczących
Przejdź do zakładki "Zarządzanie czyszczeniem" do sekcji "Edytor bazy". Znajdują się tam cztery pola edycyjne "1-4" oraz pole wyboru "5".

Wprowadź w kolejnych punktach następujące dane:
- "1" - Filtry wyszukujące zbędne pliki. Stanowią one podstawę do czyszczenia folderu.
- "2" - Filtry wykluczające ważne pliki. Jeśli wymagane jest pominięcie ważnych plików w czyszczonym folderze, ustal filtry wykluczające.

Kolejne filtry szukające lub wykluczające mogą być od siebie odseparowane znakiem ":" (dwukropek). Np.: "*.tmp:*.temp:*.bak". Ilość po sobie następujących filtrów jest dowolna.

Podanie filtra wykluczającego nie jest wymagane.

- "3" - Opis czyszczonego folderu. Może zawierać dowolne zdanie, tak abyś wiedział(a), co zdefiniowałeś(aś) do przeczyszczenia.
- "4" - Lokalizacja czyszczonego folderu. Możesz wybrać folder za pomocą przycisku [image].
- "5" - Pole wyboru. Zaznacz, jeśli czyszczenie ma się odbywać także w znajdujących się wewnątrz folderu podfolderach.

Aby dodać własny filtr czyszczący w sekcji "Edytor bazy" kliknij przycisk [image]. Na liście w zakładce "Zarządzanie czyszczeniem" nowo dodany obiekt jest już zaznaczony do czyszczenia.
Filtry czyszczące zdefiniowane przez użytkownika oznaczane są ikoną lupki z człowiekiem [image] i posiadają zielone tło. Jeśli nie chcesz czyścić tego obiektu - odznacz pole wyboru przy wpisie obiektu. Zapisz wprowadzone zmiany do bazy klikając w sekcji "Edytor bazy" przycisk "Zapisz bazę" [image] . Po zapisaniu w zakładce "Czyszczenie" pojawi się zdefiniowany nowy obiekt gotowy do czyszczenia. Obiekt ten posiada ikonę grupy [image].

Dodawanie własnych filtrów czyszczących przeznaczone jest tylko dla doświadczonych użytkowników, zapoznanych z pracą z modułem Szybkie Czyszczenie Dysku i znającymi podstawowe definicje filtrowania znane z programu Odkurzacz.

Usuwanie lub edycja własnych filtrów czyszczących
Filtry czyszczące zdefiniowane przez użytkownika oznaczane są ikoną lupki z człowiekiem [image] i posiadają zielone tło. Tylko te typy filtrów czyszczących możesz edytować i usuwać.

Aby edytować własny filtr czyszczący przejdź do zakładki "Zarządzanie czyszczeniem". Następnie podświetl swój filtr czyszczący na liście filtrów. Przejdź do sekcji "Edytor bazy". Pola wprowadzenia danych "1-4" oraz pole wyboru "5" powinno wypełnić się zdefiniowanymi danymi. Wprowadź poprawki do definiowanego filtra czyszczącego. Następnie w tej samej sekcji kliknij przycisk [image], aby zmienić filtr czyszczący. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image] .

Aby usunąć własny filtr czyszczący przejdź do zakładki "Zarządzanie czyszczeniem". Podświetl swój filtr czyszczący (lub wiele filtrów z pomocą wciśniętego klawisza Ctrl i klikaj lewym przyciskiem myszki). Możesz posłużyć się opcją wyświetlenia tylko filtrów użytkownika w sekcji "Statystyka". Następnie powracając do sekcji "Edytor bazy" kliknij przycisk [image], aby usunąć filtry czyszczące. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image] .


Monitor Czystości Dysku > Wstęp

Wybierz interesujacą Cię kategorię pomocy:

Rozpoczęcie pracy

  • Uruchomienie
  • Interfejs

Wybór obiektów do przeszukania

Rozpoczęcie skanowania

  • Skanowanie
  • Ustawienia autostartu

Usuwanie po skanowaniu


Monitor Czystości Dysku > Rozpoczęcie pracy

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Możesz też skorzystać z pomocy technicznej prowadzonej przez autora lub poprzez Oficjalne Forum programu Odkurzacz.

Uruchomienie

Aplikacja wymaga najwyższych uprawnień (Administratora), gdyż wymaga dostępu do plików zlokalizowanych na całym dysku, w tym partycji systemowej.

Aplikacja wymaga, aby przeglądarki internetowe na czas skanowania i czyszczenia były wyłączone. Jeśli Monitor Czystości Dysku stwierdzi uruchomione przeglądarki, pominie je przy czyszczeniu.

Interfejs
Interfejs aplikacji został przystosowany do szybkiego podglądu stopnia zaśmiecenia dysku. Moduł podpowiada, czy należy już oczyścić dysk.

Wszystkie ustawienia modułu odbywają się z poziomu programu Odkurzacz. Ustawienia te są tymi samymi co dla programu Odkurzacz, a więc: tryb skanowania, filtry szukające i wykluczające, czy obiekty do przeszukania.


Monitor Czystości Dysku > Wybór obiektów do przeszukania

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Ustalenie obiektów do przeszukania
Moduł wymaga zdefiniowania obiektów do przeszukania. Musisz ustalić obiekty, które chcesz przeszukać z poziomu programu Odkurzacz. Jeśli nie wiesz jak to zrobić, przejdź do działu wyboru obiektów do przeszukania.


Monitor Czystości Dysku > Rozpoczęcie skanowania

Jeśli masz problemy z ustaleniem obiektów do przeszukania, przejdź do wyboru obiektów do przeszukania.

Skanowanie
Aby ręcznie uruchomić moduł, uruchom program Odkurzacz. Kliknij logo programu [image]. Następnie z menu wybierz kolejno "Dodatkowe moduły > Monitor Czystości Dysku".

Moduł pracuje w tle, symbolizuje to ikona w zasobniku [image]. Najedź kursorem myszki na ikonę w zasobniku, aby otrzymać podpowiedź procentowego ukończenia skanowania i odnalezionych na dysku obiektów. Kliknij prawym przyciskiem myszki na ikonę, aby rozwinąć menu z opcjami. Jeśli chcesz przerwać dalsze skanowanie, wybierz z menu "Przerwij i pokaż wyniki".

Monitor Czystości Dysku nie sprawdza:
- zbędnych folderów (wykonuje to Monitor Porzuconych Folderów),
- zbędnych wpisów w rejestrze (wykonuje to Menedżer Rejestru),
- zawartości folderów na tymczasowe obiekty (wykonuje to Szybkie Czyszczenie Dysku).

Monitor Czystości Dysku spełnia tą samą rolę, co ręczne uruchamianie programu Odkurzacz i przeprowadzenie skanowania.

Ustawienia autostartu
Moduł może być uruchamiany co n-ty start systemu. W tym celu uruchom program Odkurzacz. Kliknij logo programu [image]. Następnie z menu wybierz "Ustawienia". Przejdź do sekcji "Podstawowe opcje modułów" w oknie "Ustawienia". Za pomocą opcji "Uruchamiaj monitor co # start systemu" ustal, czy moduł ma się uruchamiać z systemem, a za pomocą pola edycyjnego ustal, co który start systemu moduł ma rozpocząć skanowanie. Kliknij przycisk "Zastosuj" aby zapisać wprowadzone ustawienia.

Domyślnie moduł rozpoczyna skanowanie co 10-ty start systemu Windows. Jeśli często restartujesz komputer lub przełączasz się między kontami poprzez wylogowanie, powyższą opcją odpowiednio zwiększ odstępy między kolejnym uruchomieniem modułu.


Monitor Czystości Dysku > Usuwanie po skanowaniu

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Usuwanie znalezionych obieków z dysku
Moduł nie usuwa bezpośrednio obiektów z dysku. Może jedynie przekazać wyniki do programu Odkurzacz, z poziomu którego możesz to zrobić.
Po pojawieniu się komunikatu z podsumowaniem analizy dysku, kliknij przycisk "Uruchom Odkurzacz" (jeśli przycisk jest dostępny). Jeśli nie chcesz jeszcze czyścić dysku, zaznacz opcję "Przeczytał(em)am tą wiadomość" lub kliknij przycisk [image]. Moduł zostanie zamknięty.

Jeśli w trakcie przekazywania wyników, moduł stwierdzi, że jest uruchomiony Odkurzacz, użytkownik otrzyma stosowny komunikat "Stwierdzono uruchomiony Odkurzacz".
Jeśli wybierzesz polecenie "Przekaż później", wyniki skanowania zostaną automatycznie wczytane przy kolejnym uruchomieniu programu Odkurzacz.

Następnie oczekuj na uruchomienie programu Odkurzacz i wczytania przez niego wyników z modułu. Po zakończeniu operacji wczytywania usuń zaznaczone obiekty w Odkurzaczu. Jeśli nie wiesz jak to zrobić, przejdź do działu usuwania zaznaczonych obiektów z dysku.


Monitor Porzuconych Folderów > Wstęp

Wybierz interesujacą Cię kategorię pomocy:

Rozpoczęcie pracy

  • Uruchomienie
  • Interfejs

Rozpoczęcie skanowania

  • Skanowanie
  • Interpretacja wyników

Usuwanie po skanowaniu

  • Zaznaczanie zbędnych obiektów
  • Wykluczanie znalezionych obiektów
  • Wyrzucanie obiektów z listy
  • Tworzenie kopii bezpieczeństwa
  • Usuwanie zaznaczonych obiektów z dysku

Kopie bezpieczeństwa

  • Odzyskiwanie z kopii
  • Usuwanie kopii z dysku

Wykluczenia

  • Dodawanie własnych filtrów wykluczających
  • Usuwanie lub edycja własnych filtrów wykluczających


Monitor Porzuconych Folderów > Rozpoczęcie pracy

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Możesz też skorzystać z pomocy technicznej prowadzonej przez autora lub poprzez Oficjalne Forum programu Odkurzacz.

Uruchomienie

Aplikacja wymaga najwyższych uprawnień (Administratora), gdyż wymaga dostępu do folderów i plików na dysku.

Interfejs
Interfejs aplikacji został przystosowany do szybkiego wyboru najważniejszych poleceń. Główne menu, zwane wstążką, zostało podzielone na zakładki kategoriami. Natomiast dostęp do innych funkcji aplikacji zlokalizowany został po kliknięciu w logo programu [image]. Aby skonfigurować aplikacje, kliknij logo programu, a następnie "Ustawienia".

Z poziomu menu dostępnego poprzez logo programu, masz możliwość także szybkiego uruchomienia dodatkowych modułów, Odkurzacza lub skorzystania z pomocy technicznej.

Do każdego przycisku dostępny jest krótki opis funkcji. Jeśli masz problem z nieznanym Ci przyciskiem, najedź na niego kursorem myszki i odczekaj 2 sekundy na pojawienie się podpowiedzi. Jeśli podpowiedź nie pokazuje się, może to oznaczać, że podpowiedzi są wyłączone w ustawieniach programu Odkurzacz.


Monitor Porzuconych Folderów > Rozpoczęcie skanowania

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Skanowanie
Przejdź do zakładki "Skanowanie", a następnie w sekcji "Skanuj" kliknij przycisk "Start" [image]. Oczekuj na zakończenie operacji. Aby przerwać skanowanie w tej samej sekcji kliknij przycisk "Stop" [image] i oczekuj na zatrzymanie skanowania.
W trakcie skanowania na głównej liście w zakładce "Skanowanie", będą pojawiać się obiekty (foldery). Każdy obiekt oznaczony jest ikoną typu oraz stosownym opisem. Rozróżniane są następujące grupy obiektów:

- folder uznany za używany,
- folder uznany za używany, którego usunięcie może nie być możliwe,
- folder uznany za zbędny,
- folder uznany za zbędny, którego usunięcie może nie być możliwe.

Obiety "Używane" oznaczone są ikonami zielonymi [image] oraz [image].

Usunięcie tak oznaczonych obiektów może być niebezpieczne i nie jest zalecane dla początkujących użytkowników.

Interpretacja wyników
Każdy folder oprócz ikony typu omówionej wyżej, posiada także opis użycia folderu. Na głównej liście wyników w kolumnie "Opis" możesz odczytać użycie folderu, a także takie informacje jak lokalizacja folderu na dysku.

Z poziomu tej listy możesz przejść do lokalizacji folderu na dysku. W tym celu kliknij dwukrotnie lewym przyciskiem myszki na wybrany podświetlony folder na głównej liście.

Monitor Porzuconych Folderów oznacza zbędnymi foldery powstałe podczas instalacji poprawek dla systemu Windows.

Usunięcie folderów z dysku nie usuwa poprawek z systemu Windows. Monitor Porzuconych Folderów pozwala na usunięcie zbędnych już folderów tworzonych przy instalacji poprawek i jest to celowe i zalecane. Foldery te nie są informacją dla systemu jakie poprawki już zainstalował i usunięcie nie spowoduje ponownej ich instalacji.


Monitor Porzuconych Folderów > Usuwanie po skanowaniu

Jeśli nie rozpoczęto jeszcze skanowania, przejdź do rozpoczęcia skanowania.
Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Zaznaczanie zbędnych obiektów
Aby zaznaczyć wszystkie zbędne obiekty, na głównej liście w zakładce "Skanowanie", przejdź do sekcji "Wybierz". Następnie kliknij przycisk "Zaznacz zalec." [image] . Z listy zostaną usunięte wszystkie foldery nie będące zbędnymi.
Jeśli chcesz zaznaczyć pojedynczo foldery, na głównej liście w zakładce "Skanowanie", wybierz pole wyboru znajdujące się przy każdym obiekcie po jego lewej stronie przy ikonie grupy. W ten sposób zaznaczasz obiekty do dalszych czynności.

Jeśli chcesz zaznaczyć tylko określone grupy obiektów, w zakładce "Skanowanie" w sekcji "Wybierz" kliknij przycisk [image]. Z dostępnego menu wybierz odpowiednią grupę.
Jeśli chcesz odznaczyć tylko określone grupy obiektów, w zakładce "Skanowanie" w sekcji "Wybierz" kliknij przycisk [image]. Z dostępnego menu wybierz odpowiednią grupę.

Możesz wybierać znalezione obiekty za pomocą podświetlania folderów. W tym celu kliknij w zakładce "Skanowanie" w sekcji "Wybierz" przycisk "Podświetl" [image] . Z dostępnego menu wybierz odpowiednie polecenie.

Obiety "Używane" oznaczone są ikonami zielonymi [image] oraz [image].

Usunięcie tak oznaczonych obiektów może być niebezpieczne i nie jest zalecane dla początkujących użytkowników.

Monitor Porzuconych Folderów oznacza zbędnymi foldery powstałe podczas instalacji poprawek dla systemu Windows.

Usunięcie folderów z dysku nie usuwa poprawek z systemu Windows. Monitor Porzuconych Folderów pozwala na usunięcie zbędnych już folderów tworzonych przy instalacji poprawek i jest to celowe i zalecane. Foldery te nie są informacją dla systemu jakie poprawki już zainstalował i usunięcie nie spowoduje ponownej ich instalacji.

Wykluczanie znalezionych obiektów
Jeśli chcesz szybko dodać zaznaczone obiekty do "Wykluczeń" kliknij w zakładce "Skanowanie" w sekcji "Usuń" przycisk [image].

Wyrzucanie obiektów z listy
Jeśli chcesz uporządkować listę wyników z obiektów, których na razie nie chcesz jeszcze usuwać, możesz posłużyć się poleceniem wyrzucającym zaznaczone obiekty z listy wyników. W tym celu w zakładce "Skanowanie" w sekcji "Usuń" kliknij przycisk [image]. Zaznaczone obiekty zostaną wyrzucone z listy bez tworzenia kopii bezpieczeństwa.

Tworzenie kopii bezpieczeństwa
Monitor Porzuconych Folderów automatycznie tworzy kopię usuwanych obiektów. Jeśli chcesz samodzielnie utworzyć kopię wybranym obiektom możesz skorzystać z poleceń dostępnych w zakładce "Skanowanie" w sekcji "Kopia". Dostęp do utworzonych kopii znajduje się w zakładce "Kopie bezpieczeństwa".

Jeśli kopia nie jest tworzona, może to oznaczać, że została wyłączona w ustawieniach programu lub jest tymczasowo wyłączona poleceniem blokady kopii [image] dostępnym w zakładce "Skanowanie" w sekcji "Kopia".

Usuwanie zaznaczonych obieków z dysku
Jeśli jesteś gotowy(a) do usunięcia obiektów z dysku, kliknij przycisk "Usuń" [image] w zakładce "Skanowanie" w sekcji "Usuń". Monitor Porzuconych Folderów najpierw przystąpi do tworzenia kopii zaznaczonym obiektom, a następnie zacznie usuwać obiekty z dysku i jednocześnie z listy wyników. Jeśli chcesz przerwać usuwanie obiektów z dysku, kliknij przycisk "Anuluj" [image] w zakładce "Skanowanie" w sekcji "Usuń".

Niektóre obiekty mogą nie zostać usunięte z dysku, gdyż są zablokowane przed edycją. Takie obiekty otrzymają odpowiedni opis o problemie z ich usunięciem oraz ikonę grupy [image].


Monitor Porzuconych Folderów > Kopie bezpieczeństwa

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Odzyskiwanie z kopii
Przejdź do zakładki "Kopie bezpieczeństwa ". Aby odzyskać usunięte obiekty z wybranych kopii, zaznacz pola wyboru. Możesz posłużyć się sortowaniem, aby określić, które kopie zostały utworzone niedawno.
Po wybraniu kopii, przejdź do sekcji "Zarządzaj kopiami", a następnie kliknij przycisk "Odzyskaj" [image]. Odczekaj, aż moduł odzyska foldery z kopii.
Kopie z których foldery zostały pomyślnie odzyskane, oznaczone są ikoną [image]. W przypadku problemów, kopie oznaczone zostaną ikoną [image], wpis przyjmie tło czerwone, a użytkownik otrzyma stosowny komunikat.

Odzyskiwanie z kopii może zakończyć się niepowodzeniem, gdy odzyskiwany jest folder z kopii w miejsce istniejącego i używanego (zablokowanego do edycji) przez zewnętrzny program.

Jeśli masz problemy z odzyskaniem z kopii, uruchom program Odkurzacz i skorzystaj z odzyskiwania zaawansowanego. Monitor Porzuconych Folderów i Odkurzacz tworzą ten sam format kopii.

Usuwanie kopii z dysku
Aby usunąć wybrane kopie z dysku, przejdź do zakładki "Kopie bezpieczeństwa". Zaznacz pola wyboru przy kopiach, które chcesz usunąć. Możesz posłużyć się sortowaniem, aby określić, które kopie są najstarsze. Następnie w sekcji "Zarządzaj kopiami" kliknij przycisk "Usuń" [image]. Wybrane kopie zostaną usunięte z dysku. Możesz też usunąć ręcznie kopie z dysku. W tym celu kliknij dwukrotnie na wybraną kopię - zostanie otworzona jej lokalizacja na dysku.

Zalecane jest usunięcie kopii minimum po kilku dniach pracy z komputerem.

Kopie bezpieczeństwa w tym module nie są usuwane, gdy są przestarzałe. Wykonuje to program Odkurzacz, gdyż Monitor Porzuconych Folderów i Odkurzacz tworzą ten sam format kopii.


Monitor Porzuconych Folderów > Wykluczenia

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy

Dodawanie własnych filtrów wykluczających
Wykluczenia w module stosowane są do ignorowania wybranych folderów z określonej lokalizacji. Oznacza to, że jeden filtr wykluczający odnosi się do konkretnego jednego folderu.

Moduł udostępnia dodawanie wykluczeń przez "Edytor bazy" jednak ze względu na trudności w określeniu właściwej lokalizacji folderu z danej kategorii, z funkcji tej mogą korzystać przeważnie zaawansowani użytkownicy.

Właściwy i zalecany sposób na dodanie folderu do wykluczeń odbywa się poprzez przycisk [image] w sekcji "Usuń" w zakładce "Skanowanie" po wykonanym skanowaniu. Jeśli nie wiesz jak tego dokonać, przejdź do wykluczania znalezionych obiektów.

Aby dodać własny filtr wykluczający folder przejdź do zakładki "Wykluczenia". Następnie przejdź do sekcji "Edytor bazy" i kliknij przycisk [image]. Rozwinięte zostanie menu, które zawiera skróty, dzięki którym określisz w programie z której lokalizacji chcesz wykluczyć folder. Poniższe rozwinięcia skrótów ułatwią Ci odnaleźć właściwą lokalizację folderu który chcesz wykluczyć:

W przykładzie zastosowano ścieżki występujące w systemie Windows XP.
Folder "Documents and Settings" został zamieniony w systemach Windows Vista/7 na "Users".

Ciąg ".:\" należy przyjąć za literę partycji, zwykle jest to "C:\".

- "CommonFiles" (odnosi się do: .:\Program Files\Common Files),
- "DaneAplikacji" (odnosi się do: .:\Documents and Settings\<zalogowany użytkownik>),
- "DaneAplikacjiInnychUzytkownikow" (odnosi się do: .:\Documents and Settings\All Users\Dane aplikacji),
- "DaneAplikacjiUzytkownika" (odnosi się do: .:\Documents and Settings\<zalogowany użytkownik>\Dane aplikacji),
- "DaneAplikacjiUzytkownikaLokalne" (odnosi się do: .:\Documents and Settings\<zalogowany użytkownik>\Ustawienia lokalne\Dane aplikacji),
- "DownloadedInstallations" (odnosi się do: .:\Windows\Downloaded Installations),
- "MojeDokumenty" (odnosi się do: .:\Documents and Settings\<zalogowany użytkownik>\Moje dokumenty),
- "PartycjaSystemowa" (odnosi się do: .:\),
- "ProgramFiles" (odnosi się do: .:\Program Files),
- "ProgramData" (odnosi się do: ..:\ProgramData),
- "ProgramMenuStart" (odnosi się do: .:\Documents and Settings\<zalogowany użytkownik>\Menu Start\Programy),
- "ProgramMenuStartAll" (odnosi się do: .:\Documents and Settings\All Users\Menu Start\Programy),
- "Windows" (odnosi się do: .:\Windows).

Po wybraniu kategorii w sekcji "Edytor bazy" należy podać w polu edycji tylko nazwę folderu z powyższej wybranej lokalizacji. Następnie w tej samej sekcji kliknij przycisk [image], aby dodać filtr wykluczający. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image] . Filtry wykluczające zdefiniowane przez użytkownika oznaczane są ikoną kłódki z człowiekiem [image] i posiadają zielone tło.

Dodawanie własnych filtrów wykluczających przeznaczone jest tylko dla doświadczonych użytkowników, zapoznanych z pracą z modułem.

Wprowadzanie własnych filtrów wykluczających wiąże się z pomijaniem określonych folderów w wynikach.

Usuwanie lub edycja własnych filtrów wykluczających
Filtry wykluczające zdefiniowane przez użytkownika oznaczane są ikoną kłódki z człowiekiem [image] i posiadają zielone tło. Tylko te typy filtrów możesz edytować i usuwać.

Aby edytować własny filtr wykluczający przejdź do zakładki "Wykluczenia". Podświetl swój filtr wykluczający na liście filtrów. Następnie przejdź do sekcji "Edytor bazy". Pole wprowadzenia danych powinno wypełnić się zdefiniowanym przez Ciebie filtrem. Wprowadź poprawki do definiowanego filtra wykluczającego. Jeśli chcesz zmienić lokalizację folderu, kliknij przycisk [image] i z menu wybierz odpowiedni skrót. Następnie w tej samej sekcji kliknij przycisk [image], aby zmienić filtr wykluczający. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image] .

Aby usunąć własny filtr wykluczający przejdź do zakładki "Wykluczenia". Zaznacz pola wyboru przy swoich filtrach wykluczających. Możesz posłużyć się opcją wyświetlenia tylko filtrów użytkownika w sekcji "Statystyka". Następnie powracając do sekcji "Edytor bazy" kliknij przycisk [image], aby usunąć filtry wykluczające. Zapisz wprowadzone zmiany do bazy klikając w tej samej sekcji przycisk "Zapisz bazę" [image] .


Menedżer Rejestru > Wstęp

Wybierz interesujacą Cię kategorię pomocy:

Rozpoczęcie pracy

  • Uruchomienie
  • Interfejs

Wybór trybu

Rozpoczęcie skanowania

  • Skanowanie
  • Interpretacja wyników

Usuwanie po skanowaniu

  • Zaznaczanie zbędnych obiektów
  • Wyrzucanie obiektów z listy
  • Tworzenie kopii bezpieczeństwa
  • Usuwanie zaznaczonych obiektów z rejestru
  • Deinstalacja zaznaczonych programów

Kopie bezpieczeństwa

  • Odzyskiwanie z kopii
  • Usuwanie kopii z dysku


Menedżer Rejestru > Rozpoczęcie pracy

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Możesz też skorzystać z pomocy technicznej prowadzonej przez autora lub poprzez Oficjalne Forum programu Odkurzacz.

Uruchomienie

Aplikacja wymaga najwyższych uprawnień (Administratora), gdyż wymaga dostępu do wpisów rejestru.

Interfejs
Interfejs aplikacji został przystosowany do szybkiego wyboru najważniejszych poleceń. Główne menu, zwane wstążką, zostało podzielone na zakładki kategoriami. Natomiast dostęp do innych funkcji aplikacji zlokalizowany został po kliknięciu w logo programu [image]. Aby skonfigurować aplikacje, kliknij logo programu, a następnie "Ustawienia".

Z poziomu menu dostępnego poprzez logo programu, masz możliwość także szybkiego uruchomienia dodatkowych modułów, Odkurzacza lub skorzystania z pomocy technicznej.

Do każdego przycisku dostępny jest krótki opis funkcji. Jeśli masz problem z nieznanym Ci przyciskiem, najedź na niego kursorem myszki i odczekaj 2 sekundy na pojawienie się podpowiedzi. Jeśli podpowiedź nie pokazuje się, może to oznaczać, że podpowiedzi są wyłączone w ustawieniach programu Odkurzacz.


Menedżer Rejestru > Wybór trybu

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Wybór trybu skanowania
Aby określić typ skanowania, należy wybrać tryb skanowania. Przejdź do zakładki "Skanowanie". Następnie w sekcji "Skanuj" kliknij przycisk "Start" [image]. Następnie wybierz jeden z poniższych trybów analizy.

Dostępne są następujące tryby skanowania analizujące rejestr:
- "Konfiguracje programów" (wpisy rejestru utworzone przez zainstalowane lub choć raz uruchomione aplikacje),
- "Zainstalowane programy" (wpisy rejestru utworzone przez instalatory zainstalowanych aplikacji),
- "Rozszerzenia programów" (odwołania aplikacji do rozszerzeń plików, przez które może zostać ona uruchomiona),
- "Menu kontekstowe I" (polecenia dostępne w menu kontekstowym "Otwórz z..."),
- "Menu kontekstowe II" (polecenia dostępne w menu kontekstowym plików, folderów lub dysków),
- "Łańcuchy CLSID" (łańcuchy odwołań CLSID do aplikacji, rozszerzeń, kontrolek ActiveX, poleceń).

Jeśli jesteś gotowy(a), rozpocznij skanowanie rejestru w wybranym trybie. Jeśli nie wiesz jak postępować z wynikami, przejdź do działu rozpoczęcia skanowania.


Menedżer Rejestru > Rozpoczęcie skanowania

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Skanowanie
Przejdź do zakładki "Skanowanie", a następnie w sekcji "Skanuj" kliknij przycisk "Start" [image]. Wybierz interesujący Cię tryb analizy rejestru i oczekuj na zakończenie operacji. Aby przerwać skanowanie w tej samej sekcji kliknij przycisk "Stop" [image] i oczekuj na zatrzymanie skanowania.
W trakcie skanowania na głównej liście w zakładce "Skanowanie", będą pojawiać się obiekty (wpisy rejestru). Każdy obiekt oznaczony jest ikoną typu oraz stosownym opisem. Rozróżniane są następujące grupy obiektów:

- wpis rejestru uznany za używany,
- wpis rejestru uznany za używany, którego usunięcie może nie być możliwe,
- wpis rejestru, którego użycie nie jest znane,
- wpis rejestru, którego użycie nie jest znane oraz usunięcie może nie być możliwe,
- wpis rejestru uznany za zbędny,
- wpis rejestru uznany za zbędny, którego usunięcie może nie być możliwe.

Obiety "Używane" oznaczone są ikonami zielonymi [image] oraz [image].
Obiekty "Nieznane" oznaczone są ikonami niebieskimi [image] oraz [image].

Usunięcie tak oznaczonych obiektów może być niebezpieczne i nie jest zalecane dla początkujących użytkowników.

Interpretacja wyników
Każdy wpis oprócz ikony typu omówionej wyżej, posiada także opis użycia wpisu. Na głównej liście wyników w kolumnie "Opis" możesz odczytać użycie wpisu, a także takie informacje jak lokalizacja wpisu w rejestrze.

Z poziomu tej listy możesz przejść do lokalizacji wpisu w rejestrze poprzez systemową aplikację Edytor rejestru. W tym celu kliknij dwukrotnie lewym przyciskiem myszki na wybrany podświetlony wpis na głównej liście. Otworzy się zewnętrzna aplikacja systemu Windows, w której nastąpi przeniesienie do lokalizacji wpisu w rejestrze.

W trybie skanowania "Konfiguracje programów" (wpisy rejestru utworzone przez zainstalowane lub choć raz uruchomione aplikacje) oraz "Zainstalowane programy" (wpisy rejestru utworzone przez instalatory zainstalowanych aplikacji) Menedżer Rejestru oznacza zbędnymi wpisy powstałe podczas instalacji poprawek dla systemu Windows.

Usunięcie wpisów z rejestru nie usuwa poprawek z systemu Windows. Menedżer Rejestru pozwala na usunięcie zbędnych już wpisów tworzonych przy instalacji poprawek i jest to celowe i zalecane. Wpisy te nie są informacją dla systemu jakie poprawki już zainstalował i usunięcie nie spowoduje ponownej ich instalacji.


Menedżer Rejestru > Usuwanie po skanowaniu

Jeśli nie rozpoczęto jeszcze skanowania, przejdź do rozpoczęcia skanowania.
Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Zaznaczanie zbędnych obiektów
Aby zaznaczyć wszystkie zbędne obiekty, na głównej liście w zakładce "Skanowanie", przejdź do sekcji "Wybierz". Następnie kliknij przycisk "Zaznacz zalec." [image] . Z listy zostaną usunięte wszystkie wpisy nie będące zbędnymi.
Jeśli chcesz zaznaczyć pojedynczo wpisy, na głównej liście w zakładce "Skanowanie", wybierz pole wyboru znajdujące się przy każdym obiekcie po jego lewej stronie przy ikonie grupy. W ten sposób zaznaczasz obiekty do dalszych czynności.

Jeśli chcesz zaznaczyć tylko określone grupy obiektów, w zakładce "Skanowanie" w sekcji "Wybierz" kliknij przycisk [image]. Z dostępnego menu wybierz odpowiednią grupę.
Jeśli chcesz odznaczyć tylko określone grupy obiektów, w zakładce "Skanowanie" w sekcji "Wybierz" kliknij przycisk [image]. Z dostępnego menu wybierz odpowiednią grupę.

Możesz wybierać znalezione obiekty za pomocą podświetlania wpisów. W tym celu kliknij w zakładce "Skanowanie" w sekcji "Wybierz" przycisk "Podświetl" [image] . Z dostępnego menu wybierz odpowiednie polecenie.

Obiety "Używane" oznaczone są ikonami zielonymi [image] oraz [image].
Obiekty "Nieznane" oznaczone są ikonami niebieskimi [image] oraz [image].

Usunięcie tak oznaczonych obiektów może być niebezpieczne i nie jest zalecane dla początkujących użytkowników.

W trybie skanowania "Konfiguracje programów" (wpisy rejestru utworzone przez zainstalowane lub choć raz uruchomione aplikacje) oraz "Zainstalowane programy" (wpisy rejestru utworzone przez instalatory zainstalowanych aplikacji) Menedżer Rejestru oznacza zbędnymi wpisy powstałe podczas instalacji poprawek dla systemu Windows.

Usunięcie wpisów z rejestru nie usuwa poprawek z systemu Windows. Menedżer Rejestru pozwala na usunięcie zbędnych już wpisów tworzonych przy instalacji poprawek i jest to celowe i zalecane. Wpisy te nie są informacją dla systemu jakie poprawki już zainstalował i usunięcie nie spowoduje ponownej ich instalacji.

Wyrzucanie obiektów z listy
Jeśli chcesz uporządkować listę wyników z obiektów, których na razie nie chcesz jeszcze usuwać, możesz posłużyć się poleceniem wyrzucającym zaznaczone obiekty z listy wyników. W tym celu w zakładce "Skanowanie" w sekcji "Usuń" kliknij przycisk [image]. Zaznaczone obiekty zostaną wyrzucone z listy bez tworzenia kopii bezpieczeństwa.

Tworzenie kopii bezpieczeństwa
Menedżer Rejestru automatycznie tworzy kopię usuwanych obiektów. Jeśli chcesz samodzielnie utworzyć kopię wybranym obiektom możesz skorzystać z poleceń dostępnych w zakładce "Skanowanie" w sekcji "Kopia". Dostęp do utworzonych kopii znajduje się w zakładce "Kopie bezpieczeństwa".

Jeśli kopia nie jest tworzona, może to oznaczać, że została wyłączona w ustawieniach programu lub jest tymczasowo wyłączona poleceniem blokady kopii [image] dostępnym w zakładce "Skanowanie" w sekcji "Kopia".

Usuwanie zaznaczonych obieków z rejestru
Jeśli jesteś gotowy(a) do usunięcia obiektów z rejestru, kliknij przycisk "Usuń" [image] w zakładce "Skanowanie" w sekcji "Usuń". Menedżer Rejestru najpierw przystąpi do tworzenia kopii zaznaczonym obiektom, a następnie zacznie usuwać obiekty z rejestru i jednocześnie z listy wyników. Jeśli chcesz przerwać usuwanie obiektów z rejestru, kliknij przycisk "Anuluj" [image] w zakładce "Skanowanie" w sekcji "Usuń".

Niektóre obiekty mogą nie zostać usunięte z rejestru, gdyż są zablokowane przed edycją. Takie obiekty otrzymają odpowiedni opis o problemie z ich usunięciem oraz ikonę grupy [image].

Deinstalacja zaznaczonych programów
Jeśli wybrano tryb skanowania rejestru "Zainstalowane programy" (wpisy rejestru utworzone przez instalatory zainstalowanych aplikacji), w zakładce "Skanowanie" w sekcji "Usuń" oprócz przycisku "Usuń" [image] uaktywni się także przycisk "Odinstaluj" [image]. Dostępny jest on jedynie dla powyższego trybu skanowania rejestru.
Zaznacz pola wyboru na głównej liście wyników przy wpisach programów, które chcesz odinstalować z systemu. Następnie kliknij przycisk "Odinstaluj" [image] i oczekuj na uruchomienie deinstalatorów i zakończenie przez nich czynności. Po zakończeniu deinstalacji Menedżer Rejestru ponownie stanie się aktywny.


Menedżer Rejestru > Kopie bezpieczeństwa

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Odzyskiwanie z kopii
Przejdź do zakładki "Kopie bezpieczeństwa ". Aby odzyskać usunięte obiekty z wybranych kopii, zaznacz pola wyboru. Możesz posłużyć się sortowaniem, aby określić, które kopie zostały utworzone niedawno.
Po wybraniu kopii, przejdź do sekcji "Zarządzaj kopiami", a następnie kliknij przycisk "Odzyskaj" [image]. Odczekaj, aż Menedżer Rejestru odzyska wpisy rejestru z kopii.
Kopie z których wpisy rejestru zostały pomyślnie odzyskane, oznaczone są ikoną [image]. W przypadku problemów, kopie oznaczone zostaną ikoną [image], wpis przyjmie tło czerwone, a użytkownik otrzyma stosowny komunikat.

Odzyskiwanie z kopii może zakończyć się niepowodzeniem, gdy odzyskiwany jest wpis rejestru z kopii w miejsce istniejącego i używanego (zablokowanego do edycji) przez zewnętrzny program.

Jeśli masz problemy z odzyskaniem z kopii, możesz przejść do ich lokalizacji. Kopie rejestru są plikami REG, które mogą być importowane przez aplikację systemową "regedit.exe" dostępną w każdej wersji systemów Windows.

Usuwanie kopii z dysku
Aby usunąć wybrane kopie z dysku, przejdź do zakładki "Kopie bezpieczeństwa". Zaznacz pola wyboru przy kopiach, które chcesz usunąć. Możesz posłużyć się sortowaniem, aby określić, które kopie są najstarsze. Następnie w sekcji "Zarządzaj kopiami" kliknij przycisk "Usuń" [image]. Wybrane kopie zostaną usunięte z dysku. Możesz też usunąć ręcznie kopie z dysku. W tym celu kliknij dwukrotnie na wybraną kopię - zostanie otworzona jej lokalizacja na dysku.

Zalecane jest usunięcie kopii minimum po kilku dniach pracy z komputerem.

Kopie bezpieczeństwa w tym module nie są usuwane, gdy są przestarzałe.


Usuwanie Zablokowanych Plików > Wstęp

Wybierz interesujacą Cię kategorię pomocy:

Rozpoczęcie pracy

  • Uruchomienie
  • Interfejs

Odblokowanie i usuwanie

  • Dodanie pliku z dysku
  • Odblokowanie z usunięciem pliku z dysku
  • Niszczenie bez możliwości odzyskania pliku

Zamykanie procesu aplikacji

Kopie bezpieczeństwa

  • Odzyskiwanie z kopii
  • Usuwanie kopii z dysku

Dodatkowe narzędzia


Usuwanie Zablokowanych Plików > Rozpoczęcie pracy

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Możesz też skorzystać z pomocy technicznej prowadzonej przez autora lub poprzez Oficjalne Forum programu Odkurzacz.

Uruchomienie

Aplikacja wymaga najwyższych uprawnień (Administratora), gdyż wymaga dostępu do plików na dysku.

Moduł nie jest zgodny z systemami starszymi od Windows NT/XP. W przypadku jego uruchomienia np.: w systemie Windows 98 użytkownik otrzyma stosowny komunikat "Błąd kompatybilności".

Interfejs
Interfejs aplikacji został przystosowany do szybkiego wyboru najważniejszych poleceń. Główne menu, zwane wstążką, zostało podzielone na zakładki kategoriami. Natomiast dostęp do innych funkcji aplikacji zlokalizowany został po kliknięciu w logo programu [image]. Aby skonfigurować aplikacje, kliknij logo programu, a następnie "Ustawienia".

Z poziomu menu dostępnego poprzez logo programu, masz możliwość także szybkiego uruchomienia dodatkowych modułów, Odkurzacza lub skorzystania z pomocy technicznej.

Do każdego przycisku dostępny jest krótki opis funkcji. Jeśli masz problem z nieznanym Ci przyciskiem, najedź na niego kursorem myszki i odczekaj 2 sekundy na pojawienie się podpowiedzi. Jeśli podpowiedź nie pokazuje się, może to oznaczać, że podpowiedzi są wyłączone w ustawieniach programu Odkurzacz.


Usuwanie Zablokowanych Plików > Odblokowanie i usuwanie

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Dodanie pliku z dysku
Aby dodać plik do odblokowania, przejdź do zakładki "Odblokowanie i usuwanie", a następnie w sekcji "Dodaj" kliknij przycisk "Plik" [image] . Następnie wybierz plik (lub wiele plików przytrzymując klawisz CTRL i klikając lewym przyciskiem myszki) i potwierdź wybór przyciskiem "Otwórz". Wybrany plik zostanie dodany do listy "Obiekty usuwane" w zakładce "Odblokowanie i usuwanie". Będzie posiadał zielone tło i ikonę kłódki [image].
Aby dodać folder z plikami do odblokowania, przejdź do zakładki "Odblokowanie i usuwanie", a następnie w sekcji "Dodaj" kliknij przycisk "Folder" [image]. Wskaż folder, w którym znajdują się pliki, które chcesz usunąć i potwierdź wybór przyciskiem "OK". Pojawi się okno dialogowe "Podaj filtr" umożliwiające zdefiniowanie filtrowania dodawanych plików ze wskazanego folderu.

Domyślnie stosuje się filtr "*.*", który dodaje wszystkie pliki ze wskazanego folderu. Jeśli chcesz dodać tylko aplikacje, zastosuj np.: filtr "*.exe" (bez znaków cudzysłowia).

Moduł nie umożliwia dodania, odblokowania i usunięcia samego folderu.

Potwierdź wybór filtra przyciskiem "OK". Następnie oczekuj na dodanie plików ze wskazanego folderu. Aby przerwać dodawanie plików ze wskazanego folderu, kliknij w tej samej sekcji przycisk "Anuluj" [image].

Istnieje też możliwość dodania plików lub folderu z plikami przez funkcję "Drag&Drop". Przeciągnij pliki lub folder na listę "Obiekty usuwane".
Z tej samej funkcji "Drag&Drop" możesz skorzystać, jeśli chcesz dodać plik wybranego procesu. W tym celu w zakładce "Odblokowanie i usuwanie" z listy "Procesy aktywne" podświetl wybrany proces aplikacji. Następnie kliknij lewym przyciskiem myszki i nie zwalniając przeciągnij na listę "Obiekty usuwane". Zwolnij lewy przycisk myszki.

Dodając do listy "Obiekty usuwane" plik procesu systemowego zostanie on dla bezpieczeństwa odznaczony, a tym samym chroniony przed przypadkowym usunięciem z dysku. Plik oznaczony zostanie ikoną kłódki z wykrzyknikiem [image]. Jego ponowne zaznaczenie do usunięcia spowoduje zmianę tła na kolor czerwony.

Obiekt może przyjąć takie oznaczenie także, jeśli jego odblokowanie i usunięcie nie powiodło się.

Odblokowanie z usunięciem pliku z dysku
Jeśli jesteś gotowy(a) do odblokowania i usunięcia zaznaczonych na liście "Obiekty usuwane" plików z dysku, przejdź do zakładki "Odblokowanie i usuwanie". Następnie w sekcji "Usuń" kliknij przycisk "Usuń" [image]. Po zapoznaniu się z komunikatem dialogowym, wybierz polecenie "Kontynuuj".

Podczas procesu oblokowywania, niektóre aplikacje mogą zostać natychmiast zamknięte w tym powłoka systemowa "explorer.exe", która po zamknięciu zostanie przywrócona.

Dlatego należy zakończyć pracę z innymi aplikacjami przed rozpoczęciem procesu odblokowywania.

Rozpocznie się zautomatyzowany proces odblokowania i usuwania zaznaczonych plików z dysku. Dla każdego pliku zostanie utworzona kopia bezpieczeństwa, do której masz dostęp w zakładce "Kopie bezpieczeństwa". Cała operacja jest monitorowana w raporcie, który możesz przejrzeć po zakończeniu procesu odblokowywania i usuwania przed zamknięciem aplikacji (raport nie jest zapisywany).

Jeśli któryś z zaznaczonych plików nie został pomyślnie oblokowany i usunięty, zostanie oznaczony ikoną kłódki z wykrzyknikiem [image]. Wtedy moduł zaproponuje w komunikacie dialogowym podjęcie kolejnej próby oblokowania przy następnym starcie systemu Windows.

Niszczenie bez możliwości odzyskania pliku
Moduł umożliwia niszczenie plików tak, aby utrudnione było ich odzyskanie.

Moduł nie zapewnia bezpiecznego 100% zniszczenia plików, gdyż zastosowany algorytm jest gorszy niż algorytmy w profesionalnych aplikacjach niszczących pliki. Interacje nadpisania pliku można zwiększyć w ustawieniach modułu.

Przed rozpoczęciem niszczenia pliku nie jest tworzona jego kopia bezpieczeństwa.

Niszczenie nie może odbywać się na zablokowanym pliku. W module nie ma możliwości odblokowania, a następnie zniszczenia pliku, ponieważ opcje "Usuń" i "Zniszcz" w zakładce "Odblokowanie i usuwanie" w sekcji "Usuń" nie są ze sobą powiązane.

Jeśli do listy "Obiekty usuwane" zostały już dodane pliki do zniszczenia, przejdź do zakładki "Odblokowanie i usuwanie". Następnie w sekcji "Usuń" kliknij przycisk "Zniszcz" [image]. W komunikacie dialogowym potwierdź rozpoczęcie niszczenia zaznaczonych plików poleceniem "Kontynuuj". Oczekuj na zakończenie operacji.

Jeśli obiekt nie został pomyślnie zniszczony, oznaczony zostanie ikoną kłódki z wykrzyknikiem [image], a tło przyjmie kolor czerwony. Może to oznaczać, że plik jest zablokowany do edycji przez zewnętrzny program lub nie masz uprawnień do jego usunięcia.

Cała operacja jest monitorowana w raporcie, który możesz przejrzeć po zakończeniu procesu niszczenia przed zamknięciem aplikacji (raport nie jest zapisywany).


Usuwanie Zablokowanych Plików > Zamykanie procesu aplikacji

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Zamykanie procesu aplikacji
Czasami istnieje potrzeba zamknięcia procesu aplikacji. Okazuje się to pomocne także przy zamykaniu wielu procesów na raz, gdy jeden proces chroni drugi przed zamknięciem.
W tym celu przejdź do zakładki "Odblokowanie i usuwanie". Następnie na liście "Procesy aktywne" zaznacz pola wyboru przy procesach, które chcesz zamknąć.

Moduł rozpoznaje procesy systemowe z systemów Windows XP/Vista/7. Procesy systemowe oznaczone są tłem żółtym. Ich zaznaczenie do zamknięcia spowoduje iż przyjmą tło czerwone.

Zamykanie procesów systemowych jest niebezpieczne i może zakończyć się zamknięciem całego systemu Windows lub odmową dostępu.

Możesz posłużyć się kolumną "Lokalizacja", aby zidentyfikować procesy po lokalizacji pliku. Następnie kliknij na tej liście prawym przyciskiem myszki. Z menu wybierz polecenie "Dodaj zazn. proces do zamknięcia" [image]. Zaznaczone procesy pojawią się obok na liście "Procesy usuwane". Możesz też posłużyć się opcją "Drag&Drop" przeciągając zaznaczone procesy z listy "Procesy aktywne" do listy "Procesy usuwane". Następnie kliknij prawym przyciskiem myszki na liście "Procesy usuwane" i z menu wybierz polecenie "Zamknij wybrane procesy" [image].
Jeśli chcesz od razu zamknąć zaznaczone procesy na liście "Procesy aktywne", kliknij prawym przyciskiem myszki i z menu wybierz polecenie "Zamknij wybrane procesy" [image].

Cała operacja jest monitorowana w raporcie, który możesz przejrzeć po zakończeniu zamykania procesów przed zamknięciem aplikacji (raport nie jest zapisywany).


Usuwanie Zablokowanych Plików > Kopie bezpieczeństwa

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Odzyskiwanie z kopii
Przejdź do zakładki "Kopie bezpieczeństwa ". Aby odzyskać usunięte obiekty z wybranych kopii, zaznacz pola wyboru.
Po wybraniu kopii, przejdź do sekcji "Zarządzaj kopiami", a następnie kliknij przycisk "Odzyskaj" [image]. Odczekaj, aż moduł odzyska pliki z kopii.
Kopie z których pliki zostały pomyślnie odzyskane, oznaczone są ikoną [image]. W przypadku problemów, kopie oznaczone zostaną ikoną [image], wpis przyjmie tło czerwone, a użytkownik otrzyma stosowny komunikat.

Odzyskiwanie z kopii może zakończyć się niepowodzeniem, gdy odzyskiwany jest plik z kopii w miejsce istniejącego i używanego (zablokowanego do edycji) przez zewnętrzny program.

Usuwanie kopii z dysku
Aby usunąć wybrane kopie z dysku, przejdź do zakładki "Kopie bezpieczeństwa". Zaznacz pola wyboru przy kopiach, które chcesz usunąć. Następnie w sekcji "Zarządzaj kopiami" kliknij przycisk "Usuń" [image]. Wybrane kopie zostaną usunięte z dysku. Możesz też usunąć ręcznie kopie z dysku. W tym celu kliknij dwukrotnie na wybraną kopię - zostanie otworzona jej lokalizacja na dysku.

Kopie bezpieczeństwa w tym module nie są usuwane, gdy są przestarzałe.


Usuwanie Zablokowanych Plików > Dodatkowe narzędzia

Jeśli masz inne problemy z aplikacją wybierz inną kategorię pomocy.

Dodatkowe narzędzia
Moduł umożliwia dodatkowe uruchomienie aplikacji systemowych lub innych aplikacji. Jest to przydatne np.: w przypadku ataku szkodliwego programu (wirusa, trojana), który blokuje powłokę systemową "explorer.exe" lub ją zawiesza.
Aby skorzystać z dodatkowych narzędzi, przejdź do zakładki "Dodatkowe narzędzia". Następnie w sekcji "Uruchom program" wybierz jedno z poniższych narzędzi:

- "Explorer Windows" (uruchamia ponownie powłokę systemu Windows),
- "Edytor rejestru" (uruchamia systemowy edytor rejestru),
- "Przywracanie" (uruchamia systemowe narzędzie przywracania systemu),
- "Konfig. systemu" (uruchamia systemowe narzędzie konfiguracji systemu),
- "Konsola Windows" (uruchamia konsolę systemu),
- "Sesja Windows" (uruchamia podgląd zdarzeń systemowych),
- "Usługi systemu" (uruchamia podgląd usług systemu Windows),
- "Wybierz inny" (umożliwia wybranie innego programu do uruchomienia).

Po wybraniu polecenia odczekaj kilka sekund na uruchomienie narzędzia.